Subfolders and files not being selected


I am trying to configure Duplicati Beta ( to back up my home folder to Google Drive. I am on Ubuntu MATE 17.10.

One the source data page, I checked the box next to my home folder. Using the drop-down arrows, I verified that it checked all subfolders and files (see screenshot 1).

However, when I scroll down to the “Source Data” folder, it shows that it has added an empty “home” folder, with none of the subfolders included (screenshot 2).

If I then proceed to finish configuring the backup, and then run it, the backup finishes in less than 10 seconds, and it does not do anything except create an empty folder in my Google drive.

How do I fix this?

The “Source data” section of the folder browser is designed to only show explicitly selected folders, not any subfolders they might contain. They should still be included in the backup, just not shown in that section.

You could also think of it as that section only showing what is in the “Show advanced editor” section (use the “3 dots” menu to the right of “Source data”).

The “User data” section of the folder selector is based on the user account under which Duplicati is running, so it’s possible Duplicati is being run under a different account than the one you see when you are browsing.

Alternatively, there could be filters excluding content for some reason. Less likely but also possible is that you’re all backed up and there’s nothing else to process.

If you could export your job settings “As command-line” and paste them here (be sure to remove identifiable or security stuff like email address, passwords etc.) that might help eliminate some of the possibilities I listed above.