Subfolder problem with WebDAV

Hello, I need help with the following situation.

I have a client which has 600 computers, I want to back up all the computers using duplicati (I thought it was very good and effective). . the fact is that I want to make the transfer of the files using the WebDAV protocol, but I am presenting a problem.

I am backing up the backup on a Qnap NAS server. When I make the backup of computer 1 to the NAS, it is perfect. but when I backup the computer 2 to the NAS I get an error when I save the backup in a sub-folder.


1- the failure occurs because different folders must be made for each computer, that is, can not all backup copies be grouped in a single folder?

2- Using the FTP protocol does not present the same error, is there any difference in the configuration with WebDAV?

Best regard

1 - Each computer (and even each backup job defined on each computer) must store its data in an individual location.

If you must have this feature, Duplicacy supports something called “lock free deduplication” which allows for different computers to back up to the exact same destination. I have not tested it myself but it sounds interesting.

2 - I don’t see why FTP would be different in this regard. Duplicati’s engine does not allow backups from 2 or more different backup sets/computers to be stored in the exact same location.


It might happen because WebDAV is returning the folder+subfolder contents, where FTP is only giving the folder itself.

1 Like

I think he needs to use the --prefix switch …

A string used to prefix the filenames of the remote volumes, can be used to store multiple backups in the same remote folder. The prefix cannot contain a hyphen (-), but can contain all other characters allowed by the remote storage.
Default value: “duplicati”

That way he could just upload all the backups to a single WEBDAV target … assuming his file system supports a large number of files per directory.

1 Like

Good suggestion, I forgot about that option.
But why use that when you could just target a different subfolder of your remote storage?

1 Like


At the moment I am doing the tests with WEBDAV, since it is as I said, with whom I have the problem with the subfoldersCaptura
As you can see the image has actually worked for me, I want to thank you.


The same question I ask, when I make the first backup on computer 1, this works fine, but when making the same backup on computer 2 in a subfolder, it generates an error, where it says that there are 3 missing files.

Can you please explain as I’m not sure what you mean. When are you getting the missing files error?

example: I have 2 computers each with a backup via WEBDAV, the computer 1 performs the backup without any new, the computer 2 tries to make the backup in a subfolder. (I decided to make backup copies in subfolders when I generated an error sending all the copies in a single folder). when the second version of the backup copy is made in computer 1, it does not end indicating that 3 files are not found. . can not get clear information about the error, because it only shows me the names of the files that are missing. .

I suppose that due to this situation, and due to this problem, there is the PREFIX parameter

So it happens to me with all the computers to which WEBDAV sent the security copy

I back up several computers using WebDav and each targets its own subfolder. Works great!

Did you mean Computer2 is backing up inside a folder where Computer1 backs up? Something like this:

Computer1 - /Backups
Computer2 - /Backups/Computer2

Maybe that’s your problem. I use something like this:

Computer1 - /Backups/Computer1
Computer2 - /Backups/Computer2


1 Like

I have tested this with my Webdav server hosted by FreeNAS. It works just fine. It may have something to do with the Webdav implementation on your QNAP.

1 Like