Stuck at Verifying Backend Data

I’m using Duplicati - on Ubuntu 16.04 LTS. I’m trying to upload my backup on ERDA.

When I try to run the backup it gets stuck at Verifying backend data.
I checked the lastPgEvent and this is what is there:
lastPgEvent : {“BackupID”:“1”,“TaskID”:2,“BackendAction”:“List”,“BackendPath”:null,“BackendFileSize”:-1,“BackendFileProgress”:0,“BackendSpeed”:-1,“BackendIsBlocking”:true,“CurrentFilename”:null,“CurrentFilesize”:0,“CurrentFileoffset”:0,“Phase”:“Backup_PreBackupVerify”,“OverallProgress”:0,“ProcessedFileCount”:0,“ProcessedFileSize”:0,“TotalFileCount”:25339,“TotalFileSize”:1583289145,“StillCounting”:false}

It will be at verifying backend data for weeks on end, so I’m pretty confident it actually is stuck.

Hi @rasmusotkjaer, welcome to the forum!

It looks like the last thing Duplicati did was to request a file list from the destination (ERDA?) which had 25,339 files totaling about 1.5G so I’m assuming you’ve had this backup working successfully in the past.

To test (not fix) what’s going on, does the backup run OK if you add the --no-backend-verification=true parameter to the Options page?

If this flag is set, the local database is not compared to the remote filelist on startup. The intended usage for this option is to work correctly in cases where the filelisting is broken or unavailable.
Default value: “false”

By the way, what is “ERDA”?

I stopped the backup, selected --nobackend-verification=true, and restarted the backup. It is still stuck at Verifying backend data. If it helps I copied lastPgEvent again:

lastPgEvent : {

ERDA is the Electronic Research Data Archive at the University of Copenhagen, DK. (

Sorry, but I have to ask - did you use --nobackend-verification=true as in your post or was that a typo and you really did use the the correct --no-backend-verification=true?

(Oh, and I edited your post to make the lastPgEvent contents easier to read.)

sorry, that was a typo. I used --no-backend-verification=true (Copied it in this time).

That’s odd - I’ll have to check the code but though the --no-backend-verification parameter skipped the Backup_PreBackupVerify step.

How long has this job been running before you ran into this issue? (If you don’t remember when it started, you could at least look at the oldest version available in the Restore process.)

I run into this problem within minutes of the backup starting.

P.S. I’m fairly new to using duplicati, so please be specific if you need my help to diagnose this issue :slight_smile:

No problem - we all had to start out at some point. :smiley:

What I meant to ask was “has this job ever run successfully?”.

Yes it has. The last time was on May 13th.

OK - so something changed causing a previously working backup to start getting stuck on “Verifying Backend Data” even if --no-backend-verification=true is used.

After it fails, if you go to main menu “About” -> “Show log” -> “Live” then select “Profiling” what are the top few lines of log entries?

You should be able to copy / paste them into your post - and note that with some of them you can click on the line and it will expand to show details.

It does not fail by itself. When I have stopped the backup it prints this in About -> Show log -> live -> profiling:

"StackTraceString":"  at Duplicati.Server.Runner.Run (IRunnerData data, Boolean fromQueue) <0x409f7050 + 0x0264f> in <filename unknown>:0 \n  at Duplicati.Server.Program+<>c.<RealMain>b__36_4 (IRunnerData x) <0x409f68b0 + 0x00017> in <filename unknown>:0 \n  at Duplicati.Library.Utility.WorkerThread`1[Tx].Runner () <0x408a5a50 + 0x00510> in <filename unknown>:0 ",

Well the ThreadAbortException is an expected error when force-stopping a backup.

If you can share the few lines before the ThreadAbortException that should let us know what it was so busy working on before you had to interrupt it.