SSH Backup Location Not Working


I am trying to setup an SSH backup location on my local unraid server. I have a SMB share setup called backups.

When setting up a backup in Duplicati I select SFTP (SSH) and enter the ip of the server and the port 22.

Then in the path on server I enter “backups/laptop”. I add username and password. I have tried various ones including root to try troubleshoot. Same result with them all.

Then it will ask if I want to create the folder and I can select yes. But the folder doesn’t appear on the unraid share but when I try it again in Dup, it seems to think the folder is there.

If I run the backup will seem to work but after a while it will crash unraid (the array goes offline) and none of the files are in the backup share.

It seems like it’s creating the folder somewhere but I can’t find it anywhere on the server.

I have used the credentials in other tools and they work as expected.

Anyway got anything I can try?

Welcome to the forum @harmlessdonkey

If this turns into an Unraid question, I can’t help much, but let me get some info and give some ideas.

From placement of quote, it sounds like that’s on the server. Doesn’t it have a full path name as well?

Is this trying to get to the SMB share called backups, through Unraid? Duplicati typically is given only a relative path because the destination fills in the rest based on its setup which might be Unraid-specific although underneath Unraid, I guess there’s Linux of some sort, correct? I don’t know how hidden it is.

Meaning you can upload a file then find it? Although I don’t know why it would be different from Duplicati, Duplicati.CommandLine.BackendTool.exe will let you do manual experiments using URL modified from Export As Command-line to point to a different folder than that backup. If initially empty, you can also try Duplicati.CommandLine.BackendTester.exe for an automatic test which should take just a few minutes.

One general note is that sometimes slashes make a difference. I see your path uses a forward slash in middle, and none at start or end. This is what I usually recommend, but you could certainly try variation.

Working from command line, I would probably expect the usual double slash from URL, and then yours. Whether or not that’s correct, there should be some way to play with slashes from the command line…

The question is how far it got. The first work happens before uploads happen, but it’s not very long, and server crashing implies it got touched. You can try watching About → Show log → Live → Retry during backup to see how it ends (actually, you never described Duplicati’s end – anything noteworthy there?), however you could also set up log-file=<path> and log-file-log-level=retry to avoid missing some action.

Error logs are, unfortunately, scattered. You can also look in server log at About → Show log → Stored.
<job> → Show log → Remote will have a list near start and end of a backup, and clicking it will show what the server reported. This would probably be similar to what your BackendTool list test will show.

Okay, so I got myself all confused. I thought I was accessing an SMB share, but of course I was SSHing in so need to give the full path on the server rather than the abstracted SMB path.

Thanks for your help. I feel silly now.