Source folder does not exist: but it does (Windows mounted drive)

I’m a Duplicati newbie.
I’m backing up samba shares to a USB drive connected to a Win10 box; the samba shares are mounted as the Z: drive in Windows. I’m running three separate backups, one has run successfully, but now I get error messages for each of the three like the image attached.
All the folders do exist: copying the address text from the error message into Windows Explorer opens the directory, and the files open without a problem: the samba shared directories are all world-readable.
Can someone assist with this?

He @earthcaretech, welcome to the forum!

I suspect you’re running into a scope issue. When working with mapped drives in Windows, the drives are mapped on a per-user basis. So if your Z: drive is mounted when logged in as “User1” but Duplicati is running as “User2” it won’t see the Z: drive (or worse, it could be mapped to a different location and backing up the wrong source).

Can you tell us what version of Duplicati you’re running and whether it’s running as a service or just the tray-icon when you log in?

(Oh, and I updated the topic title to include that this is related to a Windows drive mount scenario to help people understand the content a littler more easily.)

Hi JonMikeIV

Thanks for the response.

The version of Duplicati is
Task Manager doesn’t show any services I can identify as Duplicati related, but I’m not sure what those services would be called. There is a process running called Duplicati.GUI.Trayicon.exe, so I assume it’s the tray-icon only that’s running.
There’s only one designated user on the system, the one that’s installed Duplicati, created the mapped drives, and set up the backup recipes.

There are two other symptoms, and I’m unsure if they’re related.

  1. When opening the web interface, I get an error: “Missing XSRF Token”
  2. I can’t get it to allow the interface to be opened from a remote machine, despite having ticked the box and restarted.

If you were running the server you should see two “Duplicati.Server” items (one is the server, the other a monitor to make sure the server stays running) listed in your Task Manager, like these:

The “Missing XSRF Token” error is a known issue with the version (and some of the following canary ones as well). It has mostly (fully?) been resolved in more recent canary (and possible experimental) versions.

The error itself is just related to the web GUI and does not affect the backup process. You should be able to refresh the window (such as with ctrl-F5) until the error goes away.

For more info check this out:

Where is the remote machine from which you’re trying to get access? Is it on the same network (it should work) or are you trying to connect over the Internet (likely will NOT work without router, port, firewall, etc. config)?

I just moved the installation to a service (using option 1 from Migrating from User to Service install on Windows). There were one or two additional steps required, but the service started and I logged in from the gui.

But the problem persists: tried to run one of the backups manually, and got the same folder does not exist error.

With respect to network locations, the two PCs are less than a metre apart, and definitely on the same network.

Unless you have the service running under your login I suspect this is the main source of the issue - the service account just doesn’t have Z: mapped.

What happens if you use “Show advanced editor” and manually type / paste in the UNC path rather than using Z:?

Alternatively, you could try to log in as the service account and map the drive, but this is not really a suggested method.

Sorry, you’ve stumped me: thought I knew my way around Windows pretty well.

Where do I go to use the advanced editor?

So I’ve decided to install on the Linux box, and it seems there’s no problems on any front!

When editing the Source (step 3) click on the “3 dots” menu to the right of the “Source data” label. This will change the tree view to a text box where you can manually enter each source folder (including UNC paths) on it’s own line:

So not exactly “solved” but “yay” anyway! :smiley:

Yes, I needed to have a functional back-up solution more than I needed it to be in Windows.

Thanks for the help anyway.

1 Like