[SOLVED] SQLite error cannot rollback - no transaction is active (NAS)

I am testing my “disaster recovery” capability with Duplicati (i.e., house burns down, all I have are my backup files in remote storage). Completely separate from my regular Duplicati installation on my home server, I installed Duplicati on my NAS (ReadyNAS), I went to “Restore”, and pointed the NAS installation of Duplicati to restore directly from backup files.

I select the path to the backup files, then I enter the encryption key (which I know is correct since I copied it directly from the exported config file from the other installation), and I go to select files. It churns for awhile recreating the database, and then it shows me “Restore from” with all the backups in a dropdown and a red error message at the bottom:

“SQLite error cannot rollback - no transaction is active”

I can’t move forward as there are no files to select. I searched this forum for that error and found a couple of threads, and from those I’ve manually restarted Duplicati.Service.exe (via mono), as well as Control-F5’d on the admin page, and I still get the error.

I’d love to get this working, so I can always reinstall Duplicati and recover from my backup files alone (restores work fine from my original Duplicati installation even if I just point Duplicati to the files and don’t use the existing database, so it appears to be something specific to my second installation on the NAS). I will try Duplicati on a windows machine next to see if I can eliminate the NAS installation as a culprit but if anyone has any thoughts I’d be interested.


On my NAS, the root system volume was too full. I cleared some space and everything is working.

However, I learned something that may be of use to other folks who are not necessarily linux experts (I use linux every day, and I probably should have thought of this, but I missed it). The way I installed Duplicati, it was installed to /root, which is on the very small (fixed size) root system volume on the NAS. It’s not designed to have large files written to it, and Duplicati had a few .sqlite files on there that were filling it up from previous backup runs in 2017. I never cleared them.

If you install Duplicati on a NAS device, be sure to specify the installation directory somewhere that will have room for it to grow very substantially.

Thanks for sharing that!

Another thing to watch out for are backup sqlite files that are automatically created during some database Repair / Recreate operations. They can add up if you’ve got a large database to begin with. :slight_smile:

1 Like

You’re right! If I understand you correctly, I am seeing that right now in /tmp as Duplicati recreates the database.

Good morning all,

excuse me for relaunching this topic but I have exactly the same difficulty (the post can be moved if you think it is necessary), but I am unable to reproduce the solution.

I did the same test (restore on an ARM NAS running Armbian) with the same error (installation of duplicates on a micro SD card … therefore apparently too small, not suitable, for a restore from a backup of 'approximately 1TB) and therefore having the same error message (“SQLite error cannot rollback - no transaction is active”).

From there I have two questions:

  • my production server (which I saved via duplicate) is also an ARM SBC (running under Armbian) with duplicate installed on the SD card => are there any possible difficulties (in particular space)?
  • how to specify an installation path for the installation of the duplicati .deb. I found this post (c - DESTDIR and PREFIX of make - Stack Overflow) which discusses three methods:
    ./configure --prefix = ***
    make install DESTDIR = ***
    make install prefix = ***
    But it’s a bit complicated for me. Can you please enlighten me and guide me?

Thank you very much in advance

I assume this is “Direct restore from backup files”? Where is it to, and how is destination connected?

I don’t know where you’re restoring to. This server is the source for Duplicati on the NAS attached to it.
Duplicati works best when the source files are local. Are NAS and production server SMB-connected?

You can watch space yourself, using something like df -k. If all you’re doing is backing up this server, there probably won’t be a space issue, but there could be on the NAS running Duplicati to do operation.

The sqlite files mentioned earlier wouldn’t be related to where Duplicati is installed, but to the user that Duplicati is running as. Typically the databases would be in ~ (e.g. ~root if using root) .config/Duplicati.

You can force Duplicati to use a different folder using –server-datafolder option if you find root gets full, however first you should check space to see if it’s a space issue. It might not be. Logs may be needed.

About → Show log → Live → Retry might be one place to start. Also see About → Show log → Stored.

Temporary file location is by default on the Duplicati system, but see tempdir option for controls for that.

1 Like