[Solved] Invalid password or corrupted data

Hi, on Linux I upgraded to the new beta, and tried to restore files from backups that I had created before.
I used the GUI and the restore option from the menu of two different jobs. In both cases, I got errors of this kind:

  • 2020-01-29 08:59:18 +01 - [Error-Duplicati.Library.Main.Operation.RestoreHandler-PatchingFailed]: Failed to patch with remote file: “duplicati-bccea8aa60701408da7d07f118dde9b1e.dblock.zip.aes”, message: Impossibile decriptare i dati (passphrase non valida?): Invalid password or corrupted data

  • 2020-01-29 08:59:18 +01 - [Error-Duplicati.Library.Main.Operation.RestoreHandler-RestoreFileFailed]: Failed to restore file: “/tmp/Duplicati-server.sqlite”. File hash is LST48UbnzNTz+VcsLDFNCr9Fzn4pa5GTd98yCWWowOY=, expected hash is lctQ8SK76v65D5B3HKh1XJLrXh3ndcNntu/3cjeuDYE=

This is from a job which backups the Duplicati-server.sqlite file. Since I did not enter any password, I assume the program is using the one in the job configuration, that I have not changed. This error appears if I try to restore from snapshots created both before and after the upgrade.

The last restore I performed before the upgrade dates some months ago, so I am not completely sure this depends on the upgrade.

How should I troubleshoot this? I would really like to avoid creating a new backup, because I have more that 100GB under backup and it has been running for many months.

My bad, the reason was simply an issue with Firefox autofilling a hidden form with a wrong password. See here: [Solved] AES Decryption failing

The solution was to search and remove localhost:8200 from the list of autosaved passwords and from Firefox history.

1 Like

thank u, had the exact same problem. Your resolution worked :slight_smile: