[Solved] Error AppDomains (eg. with remoting calls)

Good evening everyone, I have a Duplicati running on a Debian 8.11 and after setting up a backup job (with and without encryption), when I try to run it the first time the following error appears.

Unable to find scope in lookup table, this may be caused by attempting to transport call contexts between AppDomains (eg. with remoting calls)

I’ve already tried deleting all the contents of the ~/.config/Duplicati/* directory and searching Google, but so far I have not been able to figure out what the problem is.

Back up of Duplicati in this case is OneDrive for Bussiness.

I had the same issue and it was mono related.

In my case, a backup that had been working for months just stopped working a couple of days ago. New backup configurations also failed to the same error you are seeing. I noticed the following expired certificate error when running updater:

System.Net.WebException: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure —> System.IO.IOException: The authentication or decryption has failed. —> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server. Error code: 0xffffffff800b010a at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.RemoteValidation (Mono.Security.Protocol.Tls.ClientContext context, AlertDescription description) [0x00000] in :0

Once I installed mono from download mono everything started working again.

Thank you very much, it seems like the problem really is this. After adding the repository and reinstalling the mono it started executing 100% !!! Thank you very much.