[SOLVED] Duplicati stopped working on Ubuntu 20.04 Server (Error 100 Failed to start Duplicati web-server.)

Dear all,

suddenly duplicati stopped working on my Ubuntu Server 20.04. Iam not sure when it stopped but i did not update duplicati or anything significant on the server:

Systemctl shows the following:

ā— duplicati.service - Duplicati web-server
     Loaded: loaded (/etc/systemd/system/duplicati.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2022-04-25 15:51:18 CEST; 55s ago
    Process: 3142 ExecStart=/usr/bin/duplicati-server $DAEMON_OPTS (code=exited, status=100)
   Main PID: 3142 (code=exited, status=100)

Apr 25 15:51:18 Contro systemd[1]: duplicati.service: Scheduled restart job, restart counter is at 5.
Apr 25 15:51:18 Contro systemd[1]: Stopped Duplicati web-server.
Apr 25 15:51:18 Contro systemd[1]: duplicati.service: Start request repeated too quickly.
Apr 25 15:51:18 Contro systemd[1]: duplicati.service: Failed with result 'exit-code'.
Apr 25 15:51:18 Contro systemd[1]: Failed to start Duplicati web-server.

Rebooting did not help. Also systemctl restart gets the same error.

My installed version is: duplicati_2.0.6.3-1_all.deb

sudo lsof -i -P -n | grep LISTEN
root@Contro:~/.config# sudo lsof -i -P -n | grep LISTEN
systemd      1            root   47u  IPv4  21959      0t0  TCP *:111 (LISTEN)
systemd      1            root   49u  IPv6  21962      0t0  TCP *:111 (LISTEN)
rpcbind    867            _rpc    4u  IPv4  21959      0t0  TCP *:111 (LISTEN)
rpcbind    867            _rpc    6u  IPv6  21962      0t0  TCP *:111 (LISTEN)
systemd-r  929 systemd-resolve   13u  IPv4  32994      0t0  TCP (LISTEN)
node       999            root   17u  IPv6  40644      0t0  TCP *:443 (LISTEN)
container 1012            root   12u  IPv4  36104      0t0  TCP (LISTEN)
sshd      1024            root    3u  IPv4  32116      0t0  TCP *:22 (LISTEN)
mono      1071        www-data    5u  IPv4  35595      0t0  TCP *:8084 (LISTEN)
redis-ser 1251           redis    6u  IPv4  37383      0t0  TCP (LISTEN)
redis-ser 1251           redis    7u  IPv6  37391      0t0  TCP [::1]:6379 (LISTEN)
docker-pr 1509            root    4u  IPv4  36361      0t0  TCP *:9001 (LISTEN)
docker-pr 1516            root    4u  IPv6  36368      0t0  TCP *:9001 (LISTEN)
docker-pr 1537            root    4u  IPv4  39262      0t0  TCP *:9443 (LISTEN)
docker-pr 1544            root    4u  IPv6  37656      0t0  TCP *:9443 (LISTEN)
docker-pr 1560            root    4u  IPv4  39270      0t0  TCP *:8000 (LISTEN)
docker-pr 1568            root    4u  IPv6  39274      0t0  TCP *:8000 (LISTEN)

Shows nothing listen on port 8200

Unfortunately i cannot find any logfiles to get more details about the error, any ideas?

Thanks !

I solved the issue. The Server had an ip change recently and the old IP was defined via the DAEMON_OPTS parameter. Changed the IP to the new one and it worked again.

1 Like