[SOLVED] Duplicati Locking Up System on Debian 9.9/B2 Combination

I have come across an interesting (and frustrating) problem. I have a Debian box that I use for software development in my lab and it’s been running Duplicati successfully for more than a year. The Duplicati on the machine is configured for backups to both a local network share and a B2 bucket. This week I updated the system to Debian 9.9 and now the B2 backups consistently lock up the machine. When I say “lock up” I mean “need-to-do-a-hard-machine-reset” lock up. The local network backup seems to work fine, but the B2 backup freezes the system every time it’s run. Here’s what I’ve tried so far:

  1. I was running v2.0.4.5- and upgraded to and the system still locks up.
  2. I even went so far as to wipe and completely reload the computer, still locking up on B2 backups.
  3. I deleted everything in the B2 bucket and deleted and reconfigured a new B2 backup job. Still locking up.
  4. I installed Duplicati ( on a second “clean” Deb 9.9 test system. Same result: backup to a network share works, backup to B2 freezes.

All my other B2 backups on other systems are working fine, so I don’t think the problem is on Backblaze’s end. It’s just these (now) 2 systems that seem to be crashing with the combo of Deb 9.9 and Duplicati. At this point, I’m at a loss on where to go from here. A couple of questions for the Smart People here to hopefully help me figure out what’s happening:

  1. Has anyone seen this behavior from a Duplicati>B2 backup from Debian before?
  2. Where are the Duplicati logs stored on Debian systems where I might be able to start tracing what’s happening?
  3. Any other ideas you can think of?

Any help would be appreciated. Among other things, this is the main development system for dupReport, so having multiple backup destinations on this machine is kind of important to me :slight_smile:

Thanks in advance!



So after some additional testing I remembered that I also upgraded my firewall (an Ubiquiti Edgerouter-X) at the same time I did the OS upgrades. (I tend to batch all my updates together to minimize household downtime) The firewall was continuously becoming unresponsive (sound familiar?) so I tried downgrading the firewall OS to the prior release and - viola! - Duplicati started backing up to B2 again without error on both my systems! Problem solved!

So, Duplicati is officially absolved of any wrongdoing here, sorry for raising the alarm! I’m not sure exactly how Duplicati and the firewall were interacting to cause the crashes, but at this point I’ve got it working again so unless anyone needs more information I’m going to call this one solved and move on with my life.

Thanks, all, for listening.


1 Like

Glad you were able to solve the issue - thanks for following up!