Solution: Warnings Due to Tmp Directory Location

Hi everyone,

This is not so much a question but a message/solution to anyone in the future who is having the same problem as I was.

System: docker image of duplicati on unraid.
Backups: local external hard drive and B2 bucket.
Problem: backups seemed to be working and no actual errors were occurring, however when looking back in the logs, I would get between 3 and 5 warning messages with each backup. The number of warnings would vary, it seemed randomly, and would happen at the very end of the backup process, when duplicati seemed to be deleting and checking the files that it had put in the temp directory. Here’s an example from the log:

* 2020-04-23 13:16:46 -04 - [Warning-Duplicati.Library.Main.Operation.Backup.FileEnumerationProcess-FileAccessError]: Error reported while accessing file: /source/backup/tmp/dup-f4a130b8-2195-4a94-971f-dfa3ab7b9717
* 2020-04-23 13:16:46 -04 - [Warning-Duplicati.Library.Main.Operation.Backup.FileEnumerationProcess-PathProcessingError]: Failed to process path: /source/backup/tmp/dup-f4a130b8-2195-4a94-971f-dfa3ab7b9717
* 2020-04-23 13:16:46 -04 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: /source/backup/tmp/dup-fed0f699-6214-4984-bf49-ebe6b5988bac

The files that it was referencing were not visible in the directory itself when I would go looking for them. The problem was the same on both the local and B2 backups.

I tried searching these forums (and the unraid forums) and found some similar types of situations, but didn’t find anything that would fix this for me. To me, this was looking like a problem with duplicati’s process for deleting temp files at the end of a backup. I wasn’t (and still am not) clear on whether this problem was due to the fact that I was running it on a docker image, or whether duplicati was trying to both access and delete a file at the same time, or some other issue.

Of note, the unraid docker configuration template asks for a location for the temp directory, and I don’t know if this is unraid-specific. Originally, my tmp file was mapped within one of the shares I was backing up (which now that I think about it, seems like just asking for problems, but I didn’t see a lot of specific instructions on where to put this directory).

Solution: I created a small ramdrive which automounts via script when my system starts up and poof no more warnings. My logs show a satisfying green checkmark rather than a questionable yellow exclamation mark.

Anyway, it’s very possible that just creating another share that is not being backed up and only used for tmp would work as well, I have not tried it. I’m sure some of the more experienced users could clarify on the mechanism here. If I can get that clarity, I’ll reach out to the guys to suggest some sort of note or suggestion in the configuration template UI to keep other users from having to figure this out.

Thanks in advance and a huge thank you to all the developers who have worked on Duplicati. I am very impressed with the functionality and nice clear interface. Having a good backup solution really puts my mind at ease.

Looks like the folder Duplicati uses for its temporary files is included in your backup selection (what to back up). This should be avoided.

I run Duplicati docker image on my NAS and didn’t bother remapping the tmp directory to the host. Since the data is temporary anyway, I have no problem with that data not being persistent - it doesn’t need to survive container recreations.