Setting up Duplicati on Raspberry Pi / Ubuntu

I’m trying to set up Duplicati on a RPi 4 that I use at home as file server (Samba/NFS/FTP on 6TB drive) to backup up my stuff to my Google Drive.

Following the install guide, installing Duplicati needs Mono-Runtime, which I’ve installed the latest version of direct from their site rather than the Ubuntu Repo.
Installing Duplicati complains it’s missing a load of dependencies. Using APT to force install the needed dependencies what to install screen fulls of stuff, amounting to +350MBs of Mono.

That can’t be right, can it? Any ideas? I’m trying to keep the Pi as lean as possible.


I tried Duplicati on my Raspberry Pi 3, and the mono installation is unfortunately really big. The updates took forever and since it didn’t really solve the problem I had, I gave up eventually.

So, it does work, but it’s not “lean”!


Cheers for that Rickard, just one more question.
I’ve installed all that Mono stuff on the Pi, and tried to set up the first backup, but I get no option to encrypt the backups. Is this correct? Or have I missed something in the install?


I did my test a while ago, but as far as I remember it worked just like it should. Well, part from that OneDrive for Business did not work (at the moment OD4B did not work on Debian/Raspberry and some NASes that built on Debian, I’m not sure if that problem is fixed in current release). I would expect the encryption to work as intended, double check the backup parameters and reinstall if needed.