S3 settings not retained when editing a job


I’ve just set up my first job with Duplicati with Wasabi (S3 compatible) as the target. The job ran fine. I wanted to change the schedule, so I selected “Edit” and, when I tried to save the changes, it told me I needed the S3 access ID. I went to the target settings page and noticed that everything was reverted to the default values for a S3 target.

I reentered the values and saved and that went fine, but if I go back to edit, the target settings are reset again. I don’t know if this is common, I ran various searches and didn’t find anything similar.

I’m running on a Mac Studio with the latest OS updates.

Any idea?


Hi, welcome to the forum.

I tested to save and edit an S3 target, but it doesn’t reset for me. Maybe there is some special values in your input that are not handled properly? Can you go to the destination settings and copy the URL (in the 3-dot menu), then import it again? That should be the same process as what happens after you save. Maybe there is something strange in the URL?

OK, your URL question got me thinking. I was using a Canadian region and had to enter a custom URL. I created a new bucket using a region that’s available in the dropdown menu in Duplicati and entered the settings. Now when I go to edit the job, the settings are preserved.

Then I noticed that it was entered as a custom URL (despite selecting from the dropdown). I noticed that the uswest-1 region had a “s3” prefix, so I re-entered the information for the bucket I have in the Canadian region but added “s3.” at the beginning. Now if I go back to edit the job, everything is preserved properly. So, for some reason, even though it was able to connect without the “s3” prefix, for some reason it wasn’t preserving the settings without it. That’s an odd one alright!

Looks like all is good now, thanks! :slight_smile: