-run-script-after problem (want to backup databases after any backup)

Hi, after any backup, I’d like to instantly backup the duplicata database folder. So I found -run-script-after. I wish I could chain another backup job here. Not possible.
So I took the command line of the “Backup Databases” backup set. Does not works, -run-script-after does not loke complex command lines.
I put the command line into file U:\Duplicati_BackupDBs.cmd - it will not be started at all.

My suggestions:
-run-script-after should (at least nice to have) parse and understand complete command lines with commands, hyphens, spaces, arguments.

  • duplicati command line backup should be able to call an existing backup set by its name.

Thx :slight_smile:

I’m curious how you know it’s not started at all, as the -run-script-after feature can leave things a bit silent…

I’ve got a backup if my Duplicati databases working on Windows 7 - here’s what I did.

  1. Create a new “Duplicati_BackupDBs” backup of JUST my Duplicati “data” folder (excluding “control_dir_v2”) “Automatically run backups” UNSELECTED.

  2. Export the backup “As Command-line”

My exported command-line

“J:\Duplicati\Duplicati.CommandLine.exe” backup “file://C:_DuplicatiTest\Archives” “J:\Duplicati\data\” --thread-priority=“lowest” --backup-name=“Duplicati-Test” --dbpath=“J:\Duplicati\data\IXCPOARLFU.sqlite” --encryption-module=“aes” --compression-module=“zip” --dblock-size=“50mb” --keep-time=“3M” --passphrase=“myPass” --exclude-files-attributes=“system,temporary” --disable-module=“console-password-input” --exclude=“J:\Duplicati\data\control_dir_v2\”

  1. Paste that export into a text editor (I like Notepad++) and save it as a “C:_DuplicatiTest\Duplicati_BackupDBs.bat” batch file

  2. Added a --run-script-after setting of C:\_DuplicatiTest\Duplicati_BackupDBs.bat

  3. Verfied it ran by using the Restore option of my “Duplicati_BackupDBs” job to check see restorable backup times in line with my “primary” backup job run times.

Please let me know if the above works but still doesn’t do what you need and we can look at moving this over to the Features category for more discussion.


I was expecting for a cmd window to pop up. Now I see in task manager, it runs invisible, which is great. Problem solved, thanks for your kind reply.

Glad to hear it, and your welcome!

If you get a chance, please click the image box under the post that resolved your issue - which in this case would likely be your own. :slight_smile: This helps other users with similar issues know this is a post worth ready. Thanks!