Root filesystems used as source folders

Hi, i’m trying to use Duplicati to backup some config files I have on a Ubuntu system under /opt folder. Duplicati is running on docker but for some reason when I try to create a backup the file structure under /opt is not shown even with it correctly configured as a parameter source folder for the container. Any advice? Do I need to start the container with specific user PUID or PGIP? Tried with the user I have sudo privileges, tried to use root (code 0), but nothing worked so far.


I have no great insight about Docker since I have never used it for anything serious, did you search the forum for related posts because IIRC it’s a frequently asked question, I think that it is handled with bind mounts (but I may be wrong).

Can you see it on the Source screen? On my non-server Ubuntu /opt is a folder with 755 perms, so open for reading without permission concerns. If yours is different, or a symlink or something, results may vary.

If Duplicati can’t see it any way you try, maybe you can go in with a shell to see if things were set up right.

Can you show us your container configuration?