Rollback error during Duplicati 2 backup run

I got a string of error messages when Duplicati 2 ran my daily backup yesterday - any ideas why, and should I be worried? If I need to take action, what should that be?

This is the red box at the foot of my browser screen:

Unexpected number of remote volumes detected: 0!

And the following when I viewed the most recent of the details:

Rollback error: unknown error

No transaction is active on this connection
System.Data.SQLite.SQLiteException (0x80004005): unknown error

No transaction is active on this connection
   at System.Data.SQLite.SQLiteTransactionBase.IsValid(Boolean throwError)
   at System.Data.SQLite.SQLiteTransactionBase.Rollback()
   at Duplicati.Library.Main.Operation.BackupHandler.Run(String[] sources, IFilter filter)

I’m not sure about the “no transaction is active on this connection” errors, but the “Unexpected number of remote volumes detected” error means the Duplicati found no files on your Destination.

That is worth being worried about as it means Duplicati can’t find ANY of your backups (meaning you can’t restore).

If you connect to your destination manually (outside of Duplicati) do you see any files there?

BTW - I edited your post by putting “~~~” before and after the errors to make them easier to read.

Thank you for making my message easier to follow and for your response.
Looking at my files on the remote server, I see many zip.aes files dated 5th and 6th of January, and just one each more recently.
Details displayed for the most recent are as follows:



44672237 bytes

Last Updated:
13 Jan 2018 17:33:55 UTC


Maybe such a small file is an indication that Duplicati 2 tried and failed? I looked at the same type of data on some of the older files and that looks similar, so maybe all have failed …

I have (and am paying for storage of) 1016.97 GB but the bulk of that was uploaded with an earlier version of Duplicati which the new version seems, sadly, unable to attach to.

That is correct - Duplicati 2 does backups very differently than Duplicati 1 so the two are not cross compatible in any way. :frowning:

As for the files you’re seeing when you manually look at your destination, the one you showed details for looks OK to me. It is a “dlist” (Duplicati list) file which means it stores a list of what’s been backed up in related “dblock” (Duplicati block) files. The dlist files should almost always be smaller than the dblock files.

My guess is the many January 5 & 6 files you see are likely dblock files containing the actual backup data - did you do your first backup (or have a lot of changes) around the 5th/6th?

If you had NO files since then, then yes - I’d say there was a failure going on, but seeing the dlist file for the 13th indicates that, at least as recently as the 13th, a backup did work. Since the dlist file get created AFTER the dblock files, my guess is you’ll have at least 1 dblock file from the 12th or 13th. Though it’s possible the backup job got partially done (hence the files you have) but then crashed before it could finish.

Have you tried any backups since then? It’s possible it was a temporary problem between you and the provider.

Since you can see the files at your destination you might also want to try a test Restore.

That is alarming. I am attempting to get into the store to delete all the files that were backed up under the old software and are now useless but being paid for. :rage:

Thank you - that is reassuring. I will have to find that link to the Duplicati 2 manual again and try to understand at least some of it, so I can get at least a clue what is meant by what I see on the screen. Messages from the program, whether reporting errors or just what is going on, are not clear enough for me.

That was when I did my first attempt at backup using Duplicati 2 after this forum and my storage space provider had helped me get the settings right.

Yes, and, given what you kindly pointed out above, I assume they have worked.

Now that is a frightening prospect. I do not have a spare machine that I can risk that on! I hope only to ever have to restore if the house burns down or the computer is stolen. But I know I ought to prove it can be done. Perhaps I will feel brave enough one day, or have an IT-literate friend to watch over me while I do it.

Yep - I think many users (including myself) have that same thought. But as I’m sure many users can tell you, any backup solution is only as good as it’s ability to restore so doing test restores from time to time is always a good idea.

Even though Duplicati is pretty resilient and (by default) validates a random individual file with each backup, doing a manual restore not only gives peace of mind to you that the backup is working, but also that should the need arise (let’s say because you accidentally deleted something, not because your house burned down) you’ll know how to do it.

There are plenty of horror stories on the internet from people who were making perfectly good backups but when crunch time came for a restore (such as the boss wants last weeks version of a presentation RIGHT NOW) they get so stressed because they’re not sure how to do the restore that it takes way longer than it should.

I knew somebody who had two quotes that I have never forgotten, at least one of which might apply here.

  • "One of these days" means "none of these days"
  • If not me, then whom

If you have a spare 30 minutes sometime, consider checking these two videos out (each less than 3 minutes long) and trying a test restore a single file or two.

I had time to try Restore this weekend, but am stuck on the set-up. I had hoped the program would know all the data I entered when setting up the Backup, but clearly it does not pass this to the Restore routines. I have typed in what I can but have no idea what is meant by “Tenant name” and/or “API key” or “Container region” - all are marked optional but it is insisting on one or other of the first two before it will test the connection. Are these things I ought to know, or should I request help with these from my cloud storage space provider?

Thank you. Using the procedure shown here, I have successfully restored a file. Very happy with that!
I was surprised that this way of working to restore did pick up all my previously entered data, without my having to complete the setup screen reached when clicking “Restore” from the left hand side menu (see my reply from a little earlier today).

Same here!

By having an “in-job” restore menu item Duplicati provides an easy “no-additional-set-up” restore flow and having the main menu “restore from destination” item it provides a way to restore even if the local setup is gone (say a hard drive failure) - though additional settings are needed to try that restore method started.

At this point have all the errors you were having been “silenced”?

Still getting hundreds of errors, but much, if not all of, that may well be solved by the changes I mad a moment ago to the files being backed up. I’ll find out soon.

Are these rollback errors or something else?

Today I got

The remote server returned an error: (401) Unauthorized.

so cannot progress. Backup started OK, but when I went back to check on it, that errors showed, tried twice with same outcome.

Looks like something I need to contact the cloud storage about, unless something got broken when I adjusted the backup parameters this afternoon. Hope to have time to investigate that tomorrow.
I will also look up what a rollback error is as soon as I have time.

Sounds like you have the right idea to check with your provider, but before you do that you might want to do a “Test connection” on the job edit Destination page just to check if it was an intermittent issue or not.

I found the problem, and maybe it ought to go in as a separate topic, to make it easy to find for someone else who hits the same problem. To explain:
When I went to edit the configuration for the backup, Duplicati retained the settings I had input for almost everything, but had reverted to default for “Storage type” and lost the custom URL required.
Now I have put that all back as it ought to be, I have a backup run going as I type. If that throws up errors, I may well be back …

1 Like