Restore test: "Failed to fetch path information"

Hi experts,

today I did some restore tests to ensure that my Duplicati backups of several devices (one of them a MacBook) are working and data can be successfully restored. Backup data is stored on a S3 compatible storage (Wasabi).

I did the restore test on a clean installaton of Windows 10 and Duplicati 2.0.3.9. Most of the restores went smooth, but when I tried to restore a file out of the backup of the Macbook, I got this error message at the point when Duplicati is about to fetch the backup set information:

Failed to fetch path information: Der Index lag außerhalb des Bereichs. Er darf nicht negativ und kleiner als die Sammlung sein Parametername: startIndex

Sorry for the message to be partially in German, but this is the way it shows up, even when the Duplicati GUI language is set to English.

image

So does this mean that using a Windows 10 device to restore files from a MAC backup won’t work? Does anybody have tried this before? In many situations, this would be very helpful (imagine that you urgently need to work on a MS Office document you created on your Mac some days ago (and of course backed up with Duplicati), when all you have access to at the moment is some Windows device.

Thanks for any advice.

As far as I know this is correct - Duplicati knows it’s running on Windows so sets things like DirectorySeperator (see main menu “About” -> “System info”) based on that so when trying to restore between OSes (or more accurately, file systems) that use different pathing references it gets confused.

Theoretically, Duplicati could be updated to take pathing information from the backup (rather than the running OS) and do a conversion if necessary. However, while this could restore the files themselves (assuming max file size per OS isn’t reached) it likely would NOT be able to restore all files (think Linux files named with “:” in them) or metadata correctly (think of how differently MacOS and Windows handle file permissions.)

Working between Linux and MacOS should be fine - and theoretically, working between Linux/MacOS and Windows 10 with WSL (Windows Subsystem for Linux) should work as well.

I know there have been two or three other posts about people doing similar things cross-OS wise, but I’m not finding them in my searches right now.


I happen to have Linux, MacOS and Windows going in my environment so tested a main menu “Restore” -> “Direct restore from backup files …” from a Linux backup to a Windows 10 machine and got pretty much the same thing you did:
Failed to fetch path information: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: startIndex

All that being said, I’m guessing running Duplicati CLI in WSL on Windows 10 will likely allow you to restore. Something like the following should do the trick:
/mnt/c/Program\ Files/Duplicati\ 2/Duplicati.CommandLine.exe restore [destination location] [file(s) to restore] --restore-path=/mnt/c/DuplicatiRestore --encryption-module=aes --passphrase="[mypassword]" --disable-module=console-password-input