Restore single file from the command line

i can’t seem to restore a single file from the command line, it just starts to restore everything…

i tried listing the file as an argument with and without quotes. linux host. no spaces in file name or path, just an underscore.

Try getting rid of all the exclude lines. Some Commands appear to let you specify your file list either explicitly or implicitly by using –include and –exclude. The latter seem to “win”. I’m not sure of the intended behavior…

I’d hope that the easier (maybe) GUI Restore gets this right. Commandline leaves it to you to edit as needed.

removing the excludes did the trick. i also wasn’t sure if i had to include “” when listing the file, so i tried it both ways and it worked WITHOUT.

i was previously able to restore a single file with the GUI wizard, but there’s no way to specify options. i was doing a test restore and wanted to add the option --no-local-blocks=true to do a useful test. so that’s why i ended up trying to restore with the command line option.


You could save that in your job options any time, but I can see why you might prefer not to do that…
Advanced options cannot be set when restoring files #2185 is probably the enhancement you want.

1 Like