Restore from NFS mount: Failed to connect: No filesets found on remote targe

I previously had duplicati installed on a Linux workstation and was backing up to a NAS file system. The files are encrypted and there are a lot of *aes files on the file system. Later my drive faulted and had to get another workstation. When I try to restore from backup from the NFS mount I get the following error:

Failed to connect: No filesets found on remote target

If I click to view the logs I get the following error:
Failed to connect: SQLite error no such table: RemoteOperation

I tried from CLI and I get the same output

Any help would greatly be appreciated


Can you confirm that * files are present on your NAS? (“dlist” files are the “filesets” Duplicati is referring to.)

If they are present, it sounds like the Destination section of your backup job isn’t configured exactly right and Duplicati can’t see the files. Double check the credentials, paths, etc.


Here are the following files listed:

Total files: 22,312. All of the files end in .aes
file names with vol: 22,302
file names with manifest: 10

I don’t have any file names that have dlist. I had the backup configured to write everything to the NAS. Since then nothing has changed. Is there still a way to restore/recover the files without the dlist?


Oh, you are describing Duplicati 1.x backup files. Duplicati 2.x uses a completely different backup engine and is not compatible. You’ll want to download Duplicati 1.3.4 to do a restore.

oh ok great, thank you

For 1.3.4, what dependencies are required to get this compiled?

I assume I will need to deploy an older version of Ubuntu? v12.04 due to obsolete packages?

Honestly I have no idea… I’ve never used the 1.3.4 version before!

I think I got it. Its currently running and reading the manifest file.

What I did was I deployed a VM with Windows 10 on VMware Workstation then I installed Microsoft Framework 2.0 which is required. I downloaded and installed Duplicati 1.3.4 for Windows. From there that will allow me to successfully open the application. You will need to map a network share prior to running Duplicati. I don’t recommend installing Duplicati on Linux. I have deployed several versions of Ubuntu (12.x, 13.x, 14.x and 20.x) and I couldn’t get Duplicati to work because of the libraries and mono packages.

Thank you again for your help. Hope this helps anyone who might be in the same situation

Everything worked. I successfully restored my files

1 Like