Restore fails after upgrade to 2.0.3.3


#1

HI.

I recently accepted the automatic upgrade to 2.0.3.3_beta_2018-04-02 (on Ubuntu Linux), and now I’m getting an error when I try to do a restore:

Failed to patch with remote file: “duplicati-b5ee0c0948a29437ab0c5268022e4c93a.dblock.zip.aes”, message: Offset and length were out of bounds for the array or count is greater than the number of elements from index to the end of the source collection

Yikes! I’m currently without the ability to do a restore, which means I essentially have no backup.

In another thread somebody said they got around this by going back to version 2.0.2. I’m trying to avoid having to completely redo the backup because of internet usage cap concerns. Can I simply reinstall the .deb for 2.0.2 or will that break the database and/or backup files and require a re-backup?

Thanks.


#2

Hi @mortisj, welcome to the forum!

It is possible to downgrade to previous versions (see Downgrading / reverting to a lower version). However, I think there were some database changes made in 2.0.3.2 that make it a little more difficult than normal to go all the way down to 2.0.2.1 beta. :frowning:

It sounds like you updated to 2.0.3.3 through the web GUI, which is good because it should be pretty easy for you to try the downgrade the “easy” way. If it works, great - if not, you can just “un-downgrade” and we can try addressing the error directly.


#3

Hi JonMikeIV:

Thanks for your helpful reply.

The “easy” way of downgrading worked for me. I tried upgrading again just to see if the same error would happen, and indeed it does. If I try a restore or “verify files” in 2.0.3.3 I get the “Offset and length were out of bounds” error mentioned above. If I do the same thing in 2.0.2.1 things work fine.

Anything I can do to help track down the source of this problem?

Thanks.


#4

I’m glad the downgrade worked for you and the it stopped the errors. :slight_smile:

Thanks for the offer - unfortunately, there were a lot of changes between the two betas so tracking down the source of the issue is likely to be tricky. Particularly annoying (debugging wise) is that you aren’t the only one getting this message, but it still seems like a very small number of 2.0.3.3 users overall are experiencing it and we haven’t figured out yet what’s different about the environments of people running into it. :frowning: