Restore completed without errors but no files were restored

Could someone help me with this error, while attempting to restore a file? The restore is from Google Drive.

Warnings 1

  • 2022-11-27 19:10:02 -08 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-NoFilesRestored]: Restore completed without errors but no files were restored


Are you trying to restore from the same computer that is doing the backups ? if yes, do you select the file to restore by picking it from the UI - select the job and click “Restore-files …” from the default version ?

Yes, to the same computer.
Yes, from the UI. I navigate through the folders until I see the file in question. I select it and hit restore.

Incidentally, the same process works from an USB drive. My issue is with Google drive. “Google Drive (G:)” on my list of available drives on the computer.

Now getting the same error from the USB drive. I have included the full log below.

“RestoredFiles”: 0,
“SizeOfRestoredFiles”: 0,
“RestoredFolders”: 0,
“RestoredSymlinks”: 0,
“PatchedFiles”: 0,
“DeletedFiles”: 0,
“DeletedFolders”: 0,
“DeletedSymlinks”: 0,
“MainOperation”: “Restore”,
“RecreateDatabaseResults”: null,
“ParsedResult”: “Warning”,
“Version”: “ (”,
“EndTime”: “2022-11-28T18:52:03.5291994Z”,
“BeginTime”: “2022-11-28T18:52:00.6506756Z”,
“Duration”: “00:00:02.8785238”,
“MessagesActualLength”: 7,
“WarningsActualLength”: 1,
“ErrorsActualLength”: 0,
“Messages”: [
“2022-11-28 10:52:00 -08 - [Information-Duplicati.Library.Main.Controller-StartingOperation]: The operation Restore has started”,
“2022-11-28 10:52:01 -08 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: List - Started: ()”,
“2022-11-28 10:52:01 -08 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: List - Completed: (405 bytes)”,
“2022-11-28 10:52:01 -08 - [Information-Duplicati.Library.Main.Database.LocalRestoreDatabase-SearchingBackup]: Searching backup 0 (11/28/2022 6:05:27 PM) …”,
“2022-11-28 10:52:01 -08 - [Information-Duplicati.Library.Main.Operation.RestoreHandler-RemoteFileCount]: 1 remote files are required to restore”,
“2022-11-28 10:52:01 -08 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Get - Started: (49.99 MB)”,
“2022-11-28 10:52:03 -08 - [Information-Duplicati.Library.Main.BasicResults-BackendEvent]: Backend event: Get - Completed: (49.99 MB)”
“Warnings”: [
“2022-11-28 10:52:03 -08 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-NoFilesRestored]: Restore completed without errors but no files were restored”
“Errors”: [],
“BackendStatistics”: {
“RemoteCalls”: 2,
“BytesUploaded”: 0,
“BytesDownloaded”: 52415213,
“FilesUploaded”: 0,
“FilesDownloaded”: 1,
“FilesDeleted”: 0,
“FoldersCreated”: 0,
“RetryAttempts”: 0,
“UnknownFileSize”: 0,
“UnknownFileCount”: 0,
“KnownFileCount”: 405,
“KnownFileSize”: 6812244065,
“LastBackupDate”: “2022-11-28T10:05:27-08:00”,
“BackupListCount”: 131,
“TotalQuotaSpace”: 2000363188224,
“FreeQuotaSpace”: 1761371152384,
“AssignedQuotaSpace”: -1,
“ReportedQuotaError”: false,
“ReportedQuotaWarning”: false,
“MainOperation”: “Restore”,
“ParsedResult”: “Success”,
“Version”: “ (”,
“EndTime”: “0001-01-01T00:00:00”,
“BeginTime”: “2022-11-28T18:52:00.6506756Z”,
“Duration”: “00:00:00”,
“MessagesActualLength”: 0,
“WarningsActualLength”: 0,
“ErrorsActualLength”: 0,
“Messages”: null,
“Warnings”: null,
“Errors”: null

For clarity, where are the backup files stored, what are you trying to restore and where are you trying to restore it to?

AFAIK, Duplicati is meant to backup into a cloud service (or local storage) but it should not be used to backup from a cloud service or to backup the virtual drives/folders that cloud services create.

I backup to a local USB drive and Google drive. I am trying to restore a document, and I have tried doing so from both locations to the same computer from which it was backed up.

One interesting note. The document in question is on the “desktop.” If I restore a document on a folder (for example C:\work\PnL) the restore works.

Are you restoring a file that is missing or are you just testing with a file that is already present on your original source ? If the latter, the warning is normal.

More precisely, if file in requested location is at requested version, no restore is needed to change it.

You got no error. You got only a warning in case you were expecting the restore to change something.

If “on a folder” means “into a folder where the file does not exist”, then a restore is necessary to fix that.
If you repeat that, you’ll get a Restore completed without errors but no files were restored.
That means the Restore looked the file over, but there was no need to restore it from the backup again.

To all,
Your clarifications explained the warning message helped me further understand the software. It turns out that the file I was trying to restore was in fact on the desktop, hence the waning. Somehow, I did not see it and thought that it had been deleted.

Thank you very much for taking the time to help me!

1 Like