Resource not found: http://localhost:8200/

Hi, I updated my Win 10 installation to the latest version (duplicati-2.0.6.3_beta_2021-06-17-x64) earlier today and am now not able to open the program at all. Every time I click on the icon I get a blank window with text “Resource not found: http://localhost:8200/”. Just before updating I was able to open the program with the prior version. I tried uninstalling and re-installing but that didn’t make any difference.

I also tried disconnecting my VPN and that didnt make any difference either. I havent had any issues on the VPN before BTW.

1 Like

Hi,

Under parameters section, you can choose to grant remote connections by specifying host names allowed to connect. Have you checked that?

Cheers,

Any resolution on this?

Unfortunately this is not relevant in this situation. The OP is connecting to localhost, which is allowed by default (you don’t have to enable remote connections).

I am not sure what is causing the problem though. I haven’t seen it myself and cannot reproduce it.

Any other troubleshooting steps I could try or logs that I can pull to share? This is a big bummer for me as I have been using Duplicati to manage my cloud backups and am worried all my priors versions may become unusable as they were encrypted and broken up into pieces using Duplicati. All I did was install the latest version. It was working fine on the prior version. I actually ran a backup on the prior version and then saw the popup for update.

To watch logs you can hit F12 on most browsers (what is yours?) to open web developer tools and watch network activity when you browse to http://localhost:8200. The message sounds like the web server isn’t happy, but I don’t know why that would be. You can test a PC reboot and a web browser hard refresh.

Were you running scheduled backups? If so, can you see from the destination if they ran, despite no GUI?

How does VPN fit into the picture? Are browser and Duplicati on the same system, as localhost needs?
Any other fancy networking such as proxies that might be rewriting things?

If there’s a chance that a Duplicati process was running at the time (you’d have to check Task Manager), it might have gotten in the way of that. Best time to do this sort of thing is when you’re sure Duplicati’s down.

So I did a bunch of things and it works now. Did hard refresh and restarted and reinstalled. It started this time, but gave me another error on running the backup that it found issues in a version of the backup. I deleted that and it gave me error on a different version. I then deleted and recreated the local backup and everything seems to be working now.

1 Like

I’m glad it’s working.

Any idea which step did the trick? If not, maybe @bobhoop9 can experiment, if same issue is present.

I rolled back the update, rebooted and it came back. I had to repair the backup but it’s up and running again.

What are you on now? 2.0.6.1 would be the previous Beta, although very similar. 2.0.5.1 should have complained at least about the server database having the wrong version, although fixing it is possible.

It sounded like @Artekanon installed 2.0.6.3, although it’s not said. Would you like to try that as well?
Maybe you can figure out which of the steps that were done were the key to getting it to come up well.

Is your instance running ok now or are you affected by it all?

You’re asking me? I never reported any such issue, and it seems extremely rare (try searching).

Got it. I’m happy to have mine back up and running.

What is it running (per About screen)? I’m also curious how you rolled back the update.

Updates are stored separately from the original install, and might need manual removal.
See Downgrading / reverting to a lower version for some of the potential challenges, but
Release: 2.0.6.1 (beta) 2021-05-03 describes a DB edit that may help in some cases…

Regardless, if the update notifier goes off again, an install from .msi is always possible.
Make sure Duplicati is fully down, and it will probably give you the most reliable “update”.