Release: 2.0.3.13 (canary) 2018-10-31


#1

2.0.3.13-2.0.3.13_canary_2018-10-31

  • Added more tests, thanks @warwickmm
  • Fixed duration display in restore, thanks @verhoek
  • Refactored Dropbox backend, thanks @verhoek
  • Fixed a typo in the filter for excluding Firefox data, thanks @warwickmm
  • Fixed problem with OneDrive “eating” leading slashes, thanks @warwickmm
  • Improved Windows version detection for HyperV, thanks @mnaiman
  • Added code to allow the Windows Service to correctly autoupdate

Any progress in new beta?
#2

Upgrade from beta to this release went smoothly. Server did not restart automatically though. And a gui thing (cf. Screenshot) on a mobile device.


#3

The update server is closing downloads early (varies, running perhaps 30 seconds to 1 minute). Server TCP:

654 17.289779 139.59.135.67 192.168.0.110 TCP 506 443 → 52963 [FIN, PSH, ACK] Seq=562136 Ack=1 Win=490 Len=452 [TCP segment of a reassembled PDU]

EDIT: After trying another computer, and restarting the router, restarting the cable modem got a download from the Install button. The Activate button after Install didn’t do anything on this Windows Service install but restart the old Duplicati, but that was expected because 2.0.3.12 doesn’t yet have the update fix added for 2.0.3.13…


#4

same here, though it never has on this computer (though at least the install works smoothely otherwise, unlike in older versions).


#5

Does this mean that it works now? I can see a number of timeouts happening on the server, and it looks like the client is dropping the connection during downloads, but it is possible I messed up the server code.


#6

You need to restart the service, which should then launch 2.0.3.13, and the next update should correctly restart after updating.


#7

It works now, for me, and I’ve been using it a lot (see next paragraph). Wireshark used to look extremely messy, possibly to the point of causing the server to close, as shown on my trace above. I didn’t show the subsequent close packets, just the initiation from server side. After cable modem restart, my download benchmark is right where it should be on a random speed test (before, it was 20 Mbits/second or worse). Wireshark is showing occasional downstream packet loss (and TCP Dup Ack to recover), so looks normal. When connection was unreliable though, nothing else got to a total failure besides the Duplicati download from its update server, so something seems sensitive. A download from www.duplcati.com (S3) completed.

Agree on the first part, which is the workaround for this longstanding problem. For the second part, there’s accumulating evidence at Activate downloaded upgrade sometimes fail that it doesn’t work as it should work. Continuing the conversation there would probably be more productive, and will keep this thread uncluttered.


#8

My server is “bricked”. Doesn’t respond but process is running. One successful backup this night, then nothing. Will restart and see if that fixes things…


#9

After a restart, next backup seems to have run ok but opening the gui did show a out of memory error. Will wait another cycle to see if the error continues.