Release: 2.0.2.18 (Canary) 2018-02-11

I’ve tried 4 different browsers (IE, Edge, Chrome, FF), connected to 2 Duplicati instances (Windows 10, Netgear NAS), cleared cache, all with the same symptoms: menu keeps scrolling up and down, there’s no difference with the previous versions for me.

Duplicati reports V2.0.2.18, used the internal updater to install the latest version.

image

Just for kicks, can I get you to open the live logs in Chrome under About -> Show Log -> Live and selecting Profiling?

They’ll be invisible unless you have the new CSS that is supposed to be in 2.0.2.18

No, I did not compile it :frowning:

New version out, with recompiled CSS and updated translations.

Well … your code went into the repo, not mine :partly_sunny::cocktail:

1 Like

Issue resolved in 2.0.2.19!

1 Like

Once again, when I had --keep-versions=1 and now I change it to custom backup retention, the UI stores both options and I am doomed. Because UI still does not clean up the command line with the new settings.

It will not backup and complains:
“Setting multiple retention options (–keep-versions, --retention-policy) is not permitted”

I then can add the keep-versions via advanced options, save, remove it, save, no it will stay there. Now with Canary I have made all backups dysfunctional this way. Will probably have to export and re-import all backup definitions, or create from scratch.

EDIT/SOLUTION: I forgot, I found out about the solution some days ago.

  1. Set to “Keep all backups”
  2. Save
  3. Set to whatever retention setting
  4. Save
2 Likes

I’m now having this issue (or similar). I previously had my backup versions set to remove all backup versions older than 2 years, and (separately) a retention policy set via the Advanced Options setting to thin out backups until then. Now (for reasons I can’t guess at), Duplicati errors out when I try to run a backup job because of 2 retention settings (which worked fine before, and logically stack).

Also if I try to simply move my old “advanced options” retention policy setting (copied below), Duplicati refuses to save the configuration, complaining “Retention value must be more than 5 minutes”.

3D:0s,2W:1D,3M:1W,1Y:1M

I can’t get it to stop complaining about this, no matter what I set the value to.

Edit: @Tapio’s solution from above appears to have worked in my case too.

My followup question: If I want to use retention policy but ALSO delete all backup jobs OLDER than a certain date, matching the “Delete Backups that are older than…” setting, how do I do this? Or are we simply to assume that the retention policy completely replaces the “delete older than…” functionality altogether?

Will remove anything older than 1 year. Your new policy should be:
3D:0s,2W:1D,3M:1W,2Y:1M
To keep it for 2 years and get the exact same functionality

Edit: we made them give errors when combined to avoid causing data loss. If they didn’t you’d suddenly find you only had 1 year retention :slight_smile:
Although it’s weird with the problems reported about not being able to change the settings. Also I think we have an active issue in GitHub on "Retention value must be more than 5 minutes”.

2 Likes

Thanks, I was close but was slightly mis-interpreting the syntax I guess. I’ve now settled on this

3D:0s,2W:1D,3M:1W,1Y:1M,3Y:6M,5Y:1Y

which by my understanding means “…, for 1 year keep 1 backup per month, for 3 years keep one backup every 6 months, for 5 years keep one backup per year, and delete everything older”. This is for my work laptop so even the 5 year lifespan is over-generous :wink:

That sounds right. After 5 years you should have X+14+13+12+6+5 backups.

I like to do 13W:1W instead of 3M:1W because 3 months is like 12.8 weeks which triggers my obsessive compulsive non-disorder :wink:

1 Like

lol, fair point, i’ll probably revise to follow that since “month” is a pretty vague term when thinking about specifics.

So you’re saying it’s a good thing there’s no code for “decade” 'cause we’d have to make it be 10.0014 years? :wink:

2 Likes

I dont even know what to say…

Yeah, I would also like support for Roman numerals notation. :wink:

And don’t forget mathematical expressions

"60*60*24s:60*60s"

:wink:

image

2 Likes

That’s how I deal with leap year and leap seconds in my policy

I think this is a blocker for the experimental release. Users should be able to upgrade without hassles.

3 Likes

I think this issue is related: "Smart backup retention" causes error: Retention value must be more than 5 minutes · Issue #3010 · duplicati/duplicati · GitHub

I’ve seen a couple of variations of Duplicati not handling keep-time and retention-policy options well after retention-policy UI was added. And it got worse in 2.0.2.19 now that they’re actually mutually exclusive.

I think we should aim for some backend logic to handle this gracefully for the experimental milestone.

1 Like

Correct me if I’m wrong but it seems to me like the solution to this was (somehow successfully) clearing out the keep-time setting; the counter-intuitive thing was that simply selecting another option wasn’t sufficient to have Duplicati ignore the value that it used to hold. If I’m remembering correctly, then it seems like this particular part might be an easy thing to address within the code.

That still doesn’t help for people suddenly getting error messages because they have both values set (i.e. a keep-time setting in the UI and a retention policy via advanced option), but still…