Recreated DB: missing remote files

Just an FYI. While testing some code changes, I noticed the following behavior:

  • I deleted the local DB (well, I actually took a backup first :slight_smile: )
  • tried to recreate the DB. That completed, although it complained about (many) missing remote files.
  • I am now running list-broken-files, and that job is running now for quite some time already. It has already flagged a set of files that have to be deleted, but has not yet finished.

I would assume however that a recreate of the DB finalized with a complete working DB (as the original DB did not mention any issues).

My backup has some history which could explain this behavior. Originally, it was a much larger dataset, where I removed several folders (reducing from ~300GB of source to ~20GB of source). Could be this a side-effect of that.

Will let you know if the list-broken-files & purge-broken-files will solve my issue.


ok, purge-broken-files deleted (and replaced) 3 dlist files, now trying to delete dblock files that do not exist… after every delete, a list of remote files is generated to verify it’s actually gone… this is going to take a long time…

1 Like

What version of Duplicati and what destination are you using?

First with my own build and rclone as backend. Restarted and checking now with latest canary build. Webdav backend.

Don’t think it’s backend related. I think it’s related to my entire source moved from original location several months ago. This is causing the repair db to go wrong.

Purge still ongoing. Zero visibility on the progress as I started via the GUI…

purge stopped somehow… restarting now from command line, hope to get some more status updates over there…

Let us know if you do - my experience has been command line shows less detail. I get best results with log files & profiling log level (though honestly I haven’t tried them with a purge before…)

the standard logging gives info about files being deleted (or not deleted as they don’t exist)

4873 file to delete, 3108 done… should be finished somewhere this evning I guess…

Was your “this evening” guess correct? Anything interesting in the log?

It finished a bit earlier. Backup is running fine now with that db. Should try to delete it again and recreate it to see if the error is indeed gone. And then try to simulate what caused the issue at first.

1 Like