"Purge" is not supported?

The supplied option --purge is not 
supported and will be ignored

How can this be? I selected it via the UI. I changed my custom retention policy, hoping to purge some unneeded data and free up disk space, and followed the advice in another thread to use “purge.” I see no instructions saying “purge” must be used along with something else.


AFAIK purge is a command, and you seem to use it as an option flag. So it’s not clear to me what you are actually doing. Can you provide a screenshot ?

The --purge option you try to use does not exist. If you don’t need the space right now, you can just wait until the next backup runs. This will automatically remove all of the version that are no longer covered by your retention policy. If enough data is left unused, it will compact the storage space and combine the remaining files to free up space.

If you desperately need more space, the purge command can do this, but it does not do what you implied:

Manual: The PURGE command

Purges (removes) files from remote backup data. This command can either take a list of filenames or use the filters to choose which files to purge. The purge process creates new filesets on the remote destination with the purged files removed, and will start the compacting process after a purge. By default, the matching files are purged in all versions, but this can be limited by choosing one or more versions. To test what will happen, use the --dry-run flag.

For example, if your backup contains large files by accident which you should have excluded in your filters, you can remove them in already existing versions. You should definitely do a dry run first, to check that the include filters match what you expected.

I was trying to follow what I read in an old thread, but I’ll admit I don’t fully understand it.

Backend quota is close to being exceeded

I’ll try to study it a bit more.

Yes, this post has a small mistake in creating the link to the documentation, it should not have been --purge but just purge.