Properly stopping running backup upon linux pc shutdown

Hi, I recently started using duplicati on my (arch)linux pc. I’m backing up a lot files, so the backup takes quite long to finish, and I can’t leave my pc running all the time. Now, after a restart, I quite often get errors when duplicati tries to pick up the backup from where it was when I restarted. Errors like “unexpected difference in filesets” etc. - usually a database repair or recreating it solves the problem. But recently, I had to start from scratch due to an error.
I’m wondering if this is due to an improper way that duplicati gets shut down when I power off my pc while the backup is running - does it get interrupted? Is there a way to get duplicati to do a “proper” exit when I shut down my pc?

Hi @duplicatiomane, welcome to the forum!

Generally Duplicati shouldn’t have issues like you are describing when backups are interrupted, but it’s possible something has gotten less “recoverable” in a recent update - what version of Duplicati are you running?

The absolute safest way to stop a backup is to use the GUI and click the “x” button in the status bar which will bring up a “Stop running backup” message box with these options:

  • “Stop after upload” (Duplicati will finish what it’s doing then stop nicely)
  • “Stop now” (Duplicati will INTERRUPT what it’s doing and generate a thread abort error)
  • “Cancel” (Duplicati will go back to what it was doing)

While “Stop after upload” is the safest method to stop a backup, it’s also the one that can take the longest as you don’t necessarily know how far along Duplicati is on it’s current step.

I’d suggest you try using “Stop now” before shutting down for a few times and see if that improves on the errors that you are seeing.



I’m using Duplicati - on the manjaro archlinux derivate.
I’ll start stopping duplicati manually before shutting down my pc.
Thanks for your reply!

Thanks for the update - please let us know if this cuts down on the “fileset” etc. errors you’ve been seeing.