Problems with windows service starting

I’m running Duplicati on Windows 10 as a service. On one system with an SSD, everything is fine. On the other system with a spinning disk, and thus a much slower boot time, the windows service frequently doesn’t start on boot. When manually starting the service I would sometimes get a 1053 error. I found this page, Error 1053: "The service did not respond in a timely fashion" when attempting to start, stop or pause a service : Support, about increasing the amount of time that the windows service control will wait before deciding the service didn’t start. That seemed to help as Duplicati started on the next boot. However this morning when the system booted the Duplicati service was found to not be running. Looking through Event Viewer I found the error “Service cannot be started. The service process could not connect to the service controller”. The source of the event is listed as Duplicati.

Is this still that the service is taking a long time to start or a different error?

Interesting… don’t think I’ve heard of this problem before.

I wonder if setting the service to “Automatic (Delayed Start)” might help.

My Windows Service is not Starting when the System Boots up even though it is set to Automatic.
answer seems to be that this is related to that timeout, but you already rasied your timeout, right?

If it starts manually when the system is quieter, then maybe the suggested delayed start will do…

Windows Service fails to start #2717 gives ServicesPipeTimeout and delayed start workarounds.
IIRC when I ran a service on an old hard drive, I finally had to resort to the delayed start method…

Yes, I increased the timeout to 3 minutes. Does the error message from Duplicati “Service cannot be started. The service process could not connect to the service controller” consistent with the timeout being reached? If so, I can increase the timeout.

It’s not a Duplicati-written error, so one’s back to hitting a search engine to see what Microsoft meant.
There’s at least one person saying it’s the timeout issue, but I see a variety of answers. You can look.

You can also try to get the timout limit. I see one person saying it’s two minutes, but I don’t really know beyond my vague recollection (stated earlier) that I went with a delayed start when things were quieter.

Thank you for the feedback. I’ve increased the timeout and will continue to monitor the system. So far the service appears to be having with a 5 minute timeout.