Problems with ":" sign in a command line export


#1

If I export the configuration as a command line, the “:” character will be displayed as “%3A”. A cut and paste on the entire output without manual correction will result in an error (eg unrecognized Authid). I am using the version of 2.0.4.10_canary_2018-12-29 under windows 10.
Are there any suggestions for this?


#2

Hi @Ulrich_Pamp, welcome to the forum!

I’m a little confused where the error is coming in - does it happen when you go to run the exported command?

Are you able to post the export (with personal stuff like passphrases, email address, etc. removed) along with the actual error message?


#3

Hi JonMikeIV,

This is the result of configuration export as command line:

“C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe” backup “onedrivev2://MIF01?authid=19e5c17e1a1fb2cd10d893ea81a88dae%3A0mKd-CiJIl9XwJeDl.M2dH” “G:\Data\” --backup-name=“OneDrive Data” --dbpath=“G:\DuplicatiDBs\testa\41592495593487412920.sqlite” --encryption-module=aes --compression-module=zip --dblock-size=10MB --passphrase=xxxxxxxxxxxxx --retention-policy=“1W:1D,4W:1W,12M:1M” --disable-module=console-password-input

And this is the corresponding modification configuration backup target panel with the AuthID field:

19e5c17e1a1fb2cd10d893ea81a88dae:0mKd-CiJIl9XwJeDl.M2dH

You see the difference in the AuthID (":" vs “%3A”)

This happens since using Microsoft OneDrive V2 option.

The result is that authorization for the connection fails

Greetings


#4

Here, conversion happens on the previous OneDrive too. Do you have an authid field there if you Export as Command-line? If not, you might just not have a colon to do percent-encoding on. Such encoding is common in URLs. This URL is for target/storage/connection and is explained here (pointing back to its reference here).

By the way, the AuthID is an access secret, so if you posted it, please get another unless that one’s redacted.

I think what @JonMikelV was trying to ask was how you’re using this. The intended use, as its name implies, is to run at a Command Prompt. Does that work? It sounds like you copied authid out manually to other spots and found authid doesn’t drop right in, but arguably it shouldn’t – URLs sometimes need percent-encoding…

If you need to copy the authid, try getting it from the AuthID field of the UI, or better yet, your password saver.

The GUI AuthID form is the one with a colon that GUI and other work requires, and the “%3A” is the URL form.


#5

When exporting as command line, I have an authid field. For the example, I modified the AuthID. I use the command prompt for backup in a batch file under windows. Without modifying the command prompt, i get authorization errors. Now I take the authid from the AuthID field und that works.
Thank you for your explanations.


#6

Thank-you for sharing what worked for you.

That being said, it sounds like the GUI may be escaping the colon when doing a command line expert when it shouldn’t be.


#7

This is odd. My 2.0.4.5 onedrivev2:// URL works with colon either as itself or %3A. So does onedrive:// (though it later fails, because it’s now “Gone” from Microsoft). googledrive:// also takes colon either way.

Maybe some more reports will come in on which sort of colon other people have to use at Command Prompt. Maybe we’ll also someday hear which way it’s supposed to get exported, and whether there’s a good reason. Although colon seems (to me) fairly harmless, some other special characters may be trouble, if not encoded.