Problem installing on ubuntu 18.04 server


#1

I’m trying to install duplicati on an ubuntu 18.04 server, following the instructions on Installation - Duplicati 2 User’s Manual but when I install it I get these errors:

dpkg: dependency problems prevent configuration of duplicati:
duplicati depends on libmono-2.0-1; however:
Package libmono-2.0-1 is not installed.
duplicati depends on libappindicator0.1-cil | libappindicator3-0.1-cil; however:
Package libappindicator0.1-cil is not installed.
Package libappindicator3-0.1-cil is not installed.
duplicati depends on gtk-sharp2; however:
Package gtk-sharp2 is not installed.

dpkg: error processing package duplicati (–install):
dependency problems - leaving unconfigured
Processing triggers for mime-support (3.60ubuntu1) …
Errors were encountered while processing:
duplicati

I did install mono as described, but I get the impression duplicati needs a different version. And it seems more packages are required. I’m not very experienced in linux yet, so does anybody know how to fix this?


Linux installation instructions outdated
#2

Has nobody encountered this issue? If not, then I’m wondering what I’m doing wrong here…


#3

Can you try manually installing each dependency it’s complaining about? For example:
sudo apt install libmono-2.0-1


#4

Also, did you install Mono as explained here:
https://www.mono-project.com/download/stable/#download-lin-ubuntu


#5

I have exactly the same problem. An attempt to install libmono-2.0-1 results in error:

The following packages have unmet dependencies:
 duplicati : Depends: libappindicator0.1-cil but it is not installable or
                      libappindicator3-0.1-cil but it is not installable
             Depends: gtk-sharp2 but it is not going to be installed