Prevent Duplicati from using my OS disk for temporary files


For backup of my file server to the cloud, mostly documents and a lot of pictures, I use duplicati. But I notice it is flooding my OS drive up to the point of it only having a few MB of free space. When checking I see that in the users appdata\local\temp\2 folder there are two big files with names like dup-4473c80f-15eb-476f-b6e0-64d55e6e4215. Also a lot of smaller files.

Can someone explain to me how I can make Duplicati write these files to another drive? I’ve got a huge amount of diskspace on another disk but I can’t get Duplicati to use that drive for these files.

I’ve tried changing the database location, but I think these files aren’t database files?
I’ve re-installed Duplicati on the disk with the large amount of space but off course it still stores these files in the users appdata folde, which is on the smaller OS disk.

Does anyone know how to change this? It’s driving me kind of crazy that I can’t get that changed. Am I missing an option?

Welcome to the forum! Try setting the –tempdir option.

How much free space is on your OS drive? Duplicati typically doesn’t use a huge amount of storage for temp files, unless perhaps you’ve drastically increased the “remote volume size” option from the default 50MiB.