Phantom Errors after successful operations?

I’ve been running Duplicati 2 for quite some time, backing up my main Windows 10 box to my UnRAID servers. Recently however I began getting error notifications after every single backup, yet the logs show a clean exit. “Last successful backup” on the home page also updates as if the backup were a success.

Notification: “Got 1 warning(s)”
Log: “ParsedResult: Success” in every section

Is this a known issue? How can I verify which message is true?

The only significant thing I’ve done to correct the problem is rebuild backup databases but that had no effect on the spurious(?) notifications. (Also, I received an error notification after rebuild, though the log shows it was successful.)


Current running version is Duplicati -

Welcome and thanks for the post.

Does the log actually list “ParsedResult: Success” as a Warning?

What lines in the log are shown as Warnings?

No, the “ParsedResult: Success” output is always on it’s own line.

Note: Most of my left/right brackets “” are showing here as a box.

I’ve made my share of user errors and worked through them but in these phantom cases (every operation at this point) I’ve been unable to find any non-null warnings or errors in these log files. They’re always “Warnings/Errors: ”. Here’s an example for a backup I tried a bit ago that generated a “Got 1 warning(s)” notification:

This has me thinking Duplicati is noticing something not logged, or is fighting a “stuck” flag from an earlier error. Way too many years away from coding to help though.

New information:

Nothing was coming to mind so I created a new backup of a local C:\duptest\test.txt to d:\duptest. Same behavior. It saw that duptest didn’t exist, asked me if I wanted to create it, created it, but then immediately failed when it tried to copy files. The warning in this case is more verbose (“1 missing file”), I’m guessing because it’s the local filesystem.

Anyway, something more serious is wrong on this system. My normal backups have been properly comparing source/dest files, but the copies aren’t happening, in spite of the happy logs. Nothing stands out in Windows logs, either. I’m tempted to re-install Duplicati and see what happens.

Are you using the --run-script-after option by chance?

No, the test configs are brand new with only the minimal settings to back up a file or two from c: to d:. I have a backblaze session running for safety and will hit this again tomorrow. Thanks for all assistance!