Permissions Error

Dear All,
I earlier installed Duplicati on a fresh Ubuntu 20 server to give it a test run however, I have been getting this error when I test to backup a folder on any remote server (tested on 4 servers) in the same public network/IP subnet ranges and each time the same problem. When I view the logs in realtime I see it connects then drops and each time it try’s to connects with a variety of port numbers not sure why when I have specified a specif ssh port number. I also tried returning it to the default ssh port but that did not influence anything either.
Also I tried to look for the “Duplicati” user (to see if there is one created in Ubuntu and check its permissions and assign it group test rights) but could not find one with that name so probably it uses the “root” user (which may be an issue if making remote connections). But if anyone can help with this issue as I see online it has been mentioned a few times but no real solution as peoples setup also seem to differ.
Anyway, here is the specific error been shown:

One or more errors occurred. (Permission denied (Permission denied) (One or more errors occurred. (Permission denied)))

As indicated I even tried testing with FULL permissions on the remote folders providing the web user in ubuntu www-data and still getting the same issue so I am short on troubleshooting ideas on this one.

Any idea what sort of SFTP servers these 4 servers are? Any logs there that might give some help?

Duplicati GUI About → System info line for UserName will say what Duplicati is running as, or try ps. Generally I’d expect it would either run as root under systemd at boot, or as you after you do a login.
There’s at least one Duplicati packager (AUR, I think) that makes a duplicati user, but I think it’s rare.

Rather than go straight to the backup, try the Test connection button on the Destination screen. Backup does lots of things. Does the very first list attempt fail, or do things only fail on later work?

If you need to poke at individual operations, Export as Command-line to get a Target URL, then work
Duplicati.CommandLine.BackendTool.exe to do very custom-chosen actions to see which ones work
Duplicati.CommandLine.BackendTester.exe to an empty folder to run (maybe slower) automated test.

Have you tried another SFTP client run similarly to Duplicati to see whether it has permission issues?

Hi TS678,
Many thanks for the prompt assistance. To answer your questions:

  1. We are not really using any SFTP app per say but using the SSH that comes default with Ubuntu which runs on the standard port 22 but we changed that and also did that in Duplicati settings to reflect the change.
  2. The TEST tool works fine as we did not go straight to doing a Backup as that is the first we did when we noticed it being there. It does connect to the remote server and we even can select the files (all that seems to work fine) the issue is it wont permit the remote transfer of files onto the local install Ubuntu folder we dedicated for saving backups on the same server that Duplicati is on.
    It is not a folder permission either as we have even tried opening it 777 wide and that still produces the same error.
    Let me (when free) take a look at the links you provided to see if using the command line or any other option works.

you seem to think that Duplicati is some sort of backup server like Veeam that is pulling data from other computers. Duplicati is a simple backup software that you install on the computer you want to backup and it pushes the data to a remote target.

I can’t really follow that line, but it has “remote” and “local” and “same server”.
Does it mean SSH transfer of packaged files from Duplicati to its own system?
That makes little sense, but it’s still not clear what’s where, and what it’s doing.
I can get a little closer to making sense if I change some words around. Is this

“the issue is it won’t permit the remote transfer of files onto the remote Ubuntu folder we dedicated for saving backups from the server that Duplicati is on”? That makes more sense.

I’m guessing “TEST tool” means “Test connection” button, not BackendTester.

“select the files” sounds like a “Source Data” screen, but that makes no sense.
This would be done with local file access by Duplicati to its system, not SSH…

gpatel-fr Thanks for the clarification as it seems this may be the real issue as that is what I actually thought it does. That little piece of info helps put the picture straight. Thanks for that.
As for that ts678 Not sure what on earth he/she/it is waffling about fiddling/romanticising with semantics. If he/she/it fails to comprehend what someone else is describing does it mean it is “nonsense”? But I guess in every forum you get “that” vanity type!!
gpatel-fr once again many thanks for the clarification.

I’m glad @gpatel-fr guessed correctly. I tried to find some way to see if we had misunderstood you.
In a support forum, it’s rather common to have to guess about the situation, but sometimes it’s hard.

A good guide to what we try to do and try not to do here is at the FAQ that perhaps you saw recently

Be Agreeable, Even When You Disagree

You may wish to respond to something by disagreeing with it. That’s fine. But remember to criticize ideas, not people. Please avoid:

  • Name-calling

  • Ad hominem attacks

  • Responding to a post’s tone instead of its actual content

  • Knee-jerk contradiction

Instead, provide reasoned counter-arguments that improve the conversation.

(because that text is generic, in a support context that means help improve our ability to support you)


Looking at uses of the word “sense”, I note I’m critiquing and rejecting only my guesses at your intent.
Me not being able to make sense of something does not mean it’s nonsense (a word that I didn’t use).

well, I did a mistake myself on this forum no later than yesterday evening and ts678 corrected me and it was a most welcome and appropriate intervention. Anyone can do a guess in a given situation and it can be not completely correct but it’s not a reason to lash out like you did, maybe you misunderstood what was meant by ‘makes no sense’, in my opinion it was not personal.

1 Like