PathProcessingFailed errors after upgrading to

Yesterday I upgraded to and ever since then both of my backup sets have been throwing 26 errors/warnings with PathProcessingFailed.

Warnings: [ 
2018-11-29 09:03:02 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\maxim\AppData\Local\Packages\91750D7E.Slack_8she8kybcnzg4\LocalCache\Roaming\Slack\dictionaries\en-US.bdic, 
2018-11-29 09:03:03 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\maxim\AppData\Local\Packages\91750D7E.Slack_8she8kybcnzg4\LocalCache\Local\IconCache.db, 
2018-11-29 09:03:03 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\maxim\AppData\Local\Packages\91750D7E.Slack_8she8kybcnzg4\LocalCache\Local\Microsoft\Windows\Caches\cversions.1.db, 
2018-11-29 09:03:03 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\maxim\AppData\Local\Packages\91750D7E.Slack_8she8kybcnzg4\LocalCache\Local\Microsoft\Windows\Caches\{AFBF9F1A-8EE8-4C77-AF34-C647E37CA0D9}.1.ver0x0000000000000001.db, 
2018-11-29 09:03:03 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\maxim\AppData\Local\Packages\91750D7E.Slack_8she8kybcnzg4\LocalCache\Local\Microsoft\Windows\Caches\{AFBF9F1A-8EE8-4C77-AF34-C647E37CA0D9}.1.ver0x0000000000000002.db, ... ]

I’m running duplicati with elevated priviliges.
Same error if I have snapshot-policy auto or on.
Previous version of duplicati didn’t have this problem.

So Slack was likely running while the backup was going?

(Note that I edited your post by adding “~~~ json” before and “~~~” after the wranings to make them easier to read.)

I just tried again after a fresh reboot with Slack not running. Still same errors.
chkdsk reports no errors.

Bump? Some help with this please?

Could you elaborate on privileges? Is this a command line service install which by default runs as SYSTEM?

What about off, or does that break something else in the backup? If it does, that implies there’s something special about the files you showed. I can’t get enough Slack up to see those , so we’ll have to look at yours. You could also see if the names change from backup to backup, look at times, test copy in File Explorer, etc.

Unfortunately, the Duplicati error messages don’t give much detail about exactly what went wrong with these. Running the backup on the job’s Commandline option gives a bit more, but you have to copy going far right.

Right now I don’t know if the problem is VSS-related, permission-related, or something else. Need to narrow.

Right-click, “Run as Administrator”.

With that setting removed I now get these, in addition to the above warnings.

        2018-12-07 18:54:47 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-CheckingErrorsForIssue1400]: Checking errors, related to #1400. Unexpected result count: 0, expected 1, hash: nYI4W3DuDUruaxSjIbaoheGAqqzKAvPx7cGl8MyCPqw=, size: 102400, blocksetid: 324357, ix: 102, fullhash: sxcantNsPbT0Jo/MZlOkkXXVcOXPhzqQjI7Qw3vf9N8=, fullsize: 10669090,
        2018-12-07 18:54:47 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-FoundIssue1400Error]: Found block with ID 741183 and hash nYI4W3DuDUruaxSjIbaoheGAqqzKAvPx7cGl8MyCPqw= and size 88852,
        2018-12-07 18:54:48 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-CheckingErrorsForIssue1400]: Checking errors, related to #1400. Unexpected result count: 0, expected 1, hash: e5kAcCdxlkQjY8bCRBkNN5smCZjAh0TOQ5xx/QejcJA=, size: 102400, blocksetid: 324359, ix: 202, fullhash: hEi0BBnylUu83mywNWe0m6RKac9F/o8IPjpNNp/6kIs=, fullsize: 20863668,
        2018-12-07 18:54:48 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-FoundIssue1400Error]: Found block with ID 741391 and hash e5kAcCdxlkQjY8bCRBkNN5smCZjAh0TOQ5xx/QejcJA= and size 76364,
        2018-12-07 18:55:18 -05 - [Error-Duplicati.Library.Main.Database.LocalBackupDatabase-CheckingErrorsForIssue1400]: Checking errors, related to #1400. Unexpected result count: 0, expected 1, hash: 6HMn8VQrGy3FqBqpnxj1mByoWsAYEchQZ3n6ddUaJZg=, size: 102400, blocksetid: 324871, ix: 27, fullhash: KIBFQ+9j9wLg56LEskq2Zvx0tPFvjncOD2ZJwDlCD3g=, fullsize: 2869904,

Filenames do not change.
I tried to manually copy those files using file explorer and Total Command, both running in admin mode and got permission denied errors. :confused:

Strangely enough I now started getting similar warnings on my osx laptop.

2018-12-10 09:32:29 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: /Users/maxim/.config/Duplicati/PFXXFDDNSX.sqlite-journal

Files being backed up and backup destinations are completely different.

What are you right-clicking? My guess is this was your desktop icon for “Duplicati 2”. If not, please clarify this.

There are lots of ways to run Duplicati. For example, installing it as a Windows service gives one the ability to back up files from all users. Doing that install requires manually running Duplicati.WindowsService.exe install. Not doing it means Duplicati is not as elevated as the SYSTEM account it defaults to, if installed as a service.

Although error messaging varies, your error messages from File Explorer and Total Command sound like the problem is permissions not locking. My test with Windows File Explorer to copy a locked file gave a very good error message, even saying what had the file locked. I’d still like to hear from Duplicati which issue it’s having:

would be a direct way to (I hope) hear more from Duplicati on why it can’t get into the file. This option is on every backup job menu as Commandline, and is pre-filled from the job. Make sure the Command at top is backup (sometimes it comes up as help for some reason), then press the Run "backup" command now.

The FoundIssue1400Error is Failed to process path: xxx => Unexpected result count: 0, expected 1 #1400 debug code for something fixed in 2016 which has seemingly made a reappearance, maybe in different form. Worrisome to see that, but I don’t see how it could explain why you can’t read the files, so I won’t pursue now. Might as well go back to using VSS just to stop some of the noise while checking permissions on those files…

Do file dates or sizes change? I still don’t know what those files or area are (perhaps you can look into it too) however if the entire folder is what Slack calls their cache, possibly there’s a way to influence the files a little:

Slack for Windows (Beta)- Release Notes
For the times when Slack just... doesn't: try Help > Clear Cache and Restart. It has all the nougaty goodness of Reset App Data, without the stale aftertaste of losing your teams.

and you can search in site:,, and for more, primarily on whether there’s any loss you might care about. What could happen, though, is the files could just come back again with the same access problem. You could also check Windows’ services for any Slack ones.

/Users/maxim/.config/Duplicati/PFXXFDDNSX.sqlite-journal is likely the PFXXFDDNSX.sqlite DB’s rollback journal file which goes with that job’s database, whose pathname you can find on job’s Database tab. Having it be locked while its backup job is running is probably normal, though snapshot-policy will use VSS to read what it can, and just waste some space. Don’t try to restore a database grabbed this way while in use…

Duplicati’s entry in my start menu… the same way I’ve been running it ever since i started using it…

I have not switched to the service mode yet. Running it just as user.

I don’t have the error message in front of me right now. Once I’ll get home i’ll try it again and I’ll try to run duplicati from cli.

From what I understand that folder is where Windows App Store installs Slack’s app files. It is not cache. Cache is saved elsewhere and I explicitly exclude that folder.

Note that this instance of the message is coming from my osx laptop, not Windows, so there’s no “VSS”…

I’m getting a similar error, but with Microsoft Edge

Warnings: [
    2019-01-02 17:21:16 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\alexa\AppData\Local\Microsoft\WindowsApps\MicrosoftEdge.exe,
    2019-01-02 17:21:16 -05 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: C:\Users\alexa\AppData\Local\Microsoft\WindowsApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe

Same version of Duplicati, Windows 10, snapshot policy set to required, as my backup would always fail on opened files.

Unfortunately PathProcessingFailed is a very generic error, and the details are on later lines which aren’t given on these short summaries. Especially for a reproducible backup problem, the easiest path to a nice report may be to use the job’s Commandline option to run the backup. I think the email reports which some people arrange may get information beyond what the default logs have. For hard-to-catch errors, one could also set a –log-file, or for a similar view (in reverse chronological order, and live), try About --> Show log --> Live --> Warning (etc.).

For now, I cheated a bit and excluded from EXE from the backups. I’ll revisit the issue if it still exist after another Beta release.

Thanks for the info. It made me discover the command line tool, which was insanely useful for fixing other problems. I hope to setup log files once I have an adequate log rotation solution.