Options missing after switch to Experimental channel

After switching from the Beta to the Experimental channel, backups and restores work, but there is some weird behaviour.

If I point the web browser to localhost I can see the Smart Retention feature, but choosing it and saving doesn’t apply it. (If I revisit the same page, the setting is unchanged.) If I point the web browser to, I don’t see an option for Smart Retention at all.

I am running Duplicati as a service on this machine (a server). It seems like I’ve managed to run a couple of copies of the web interface. But I should at least be able to get the retention feature to apply on the web interface on localhost, no?

I’ve tried restarting the Duplicati service as well.

Bah! I had started a copy of the Duplicati web interface from the desktop, in addition to the Duplicati service.

Once the desktop copy of Duplicati was closed things seem better.

Yeah…that’s almost a common enough mistake to cause a rewrite of that functionality. But there’s so much cooler stuff on the way it just hasn’t gotten very high on the list yet. :slight_smile:

Should we flag this topic as Solved with your last post?

I have to concur that the way running a service works right now is not quite idiot proof. But that is a very quiet criticism.

Yes, my problem is solved.

Yeah… it was designed that way on purpose, but I think the target user base is changing enough that some discussions have already happened about “flipping” the functionality to automatically attach to any existing server and require a parameter to NOT do so, rather than the current opposite functionality.

The way it currently works is probably better for multi-user environments.