Only restores empty folders

After wasting 2 days with the mac osx app (it doesn’t work at all. Doesn’t store, or else hangs in a million different places, even the cli), I am now trying with the windows app.

It starts off well. It opens the archive. It sees the 3 backup dates. I poke around and see my files. I select everything. I choose a restore location. It does its thing.

Result: Every folder is empty. A perfect 10k folders, all of them completely empty!

I guess there is an error: “illegal character in path” but when I click for details, it says that everything went well, no errors!

Please, I just want my data back. I’ll donate the $10 if you can just give me that.


From the rest of your post, you seem to want to do a restore, so you should have had a working Duplicati version installed at some point ? How could it be possible that you can’t install it again ?

Well, trying to do a restore cross system is more difficult (if the original system is a Mac that is)

Problem not known so far. Can you try to restore just one file to see how it goes ?

This is not clear. Can you provide screenshots ?

Do you really consider that doing a donation is equivalent to a backdated support contract ? For the record, none of the persons usually answering on this forum is getting a cent out of the donations.

Are the files you look for there in the recovery selection? If not, that is probably bad. If yes, try to select just one without special characters to see if it restores correctly in that case.

There is a more detailed live log on the About page, keep that open while you do the restore and see if there are warnings there.

You might be able to find previous issues in About → Show log → Stored. Check times, try expand.

For looking for failure, try About → Show log → Live → Warning (or similar) while doing the restore.
That’s probably enough to get a view of the error, but you can use Verbose level if you prefer more.

Is this saying that the data is now gone? Until this sentence, it sounded like this was some early test.


The other-post questions need answers too. What made the backup that’s having trouble restoring?
Whatever it was, something apparently made 3 backup dates. Which OS had backup Source Data?

This is the first write. After that, it starts looking at source and restore area for existing blocks to use.
The various phases (there appear to be 11 possible) of a restore are shown in the status bar at top.

You probably hit an error in one of them and ended early, but we need to know some error specifics.
Knowing systems and backups will help identify possible points where you might have hit a problem.

Yes. This ultimately worked for me. I was able to select everything that wasn’t in a hidden folder. I think it’s a good 95% so I just hope there was nothing important in the hidden folders… :pray:

Yes, that was many years ago. I should have originally said that my backup is dated 2017. It’s an old backup that I want to migrate to a new backup app. I have similar old backups from Crashplan that I need to migrate as well. Backups are work!

Yup but it’s not like I have a choice. I tried 2.0.4, 5, 6 and 7. I also tried 1.3.4. which didn’t work even when I installed a really old version of Mono, it still complained about that.

A single restore does work.

Yeah, it isn’t clear! Sorry, I was able to do a partial restore and I’m just going to cut my losses at this point :frowning:

It’s desperation. It’s a bribe.

Oh yes of course, the about page is the perfect place for more logs to be! I’m sorry but this software is just so bad! I think that I already closed the tab and like I said, I’m just going to cut my losses at this point. I’ve done more than anyone should ever have to.

No, it did just seem like I was never going to be able to restore anything. After stumbling at every single point in the journey it just didn’t seem possible to get anything back. Thankfully I was wrong.

Originally done on a mac in 2017 or earlier with Duplicati.

Is this preserved after a restart? Or even just closing the browser tab? If so then I can probably still get. I’ll check when I get home.

I must say I’m impressed at the number of fine people willing to help out a stranger on the internet who used a free piece of software 6 years ago. :saluting_face: Thank you

I’m not sure of the internal details, but reopening a closed tab brings back some of the recent history. Restart probably loses it. Viewing the log files of a backup job gets logs from the job’s own database, however if there are no results to report, e.g. due to fatal error, it’s Viewing the Duplicati Server Logs. These logs are in the Duplicati-server.sqlite database, so should be very resilient even after a reboot.

I suspect some of this is historical. Originally there was the command line only, then the server came.

should improve the confusing situation with the two different logs, in the next Canary or Beta release.


and the below should improve the annoying situation where sometimes it chops off the details of error
which then forces one to hope that it’s reproducible so that one can get things like filename in live log.

had an interesting history, but I don’t know what you ran. macOS 12.3 deleted Python 2 thus broke us. Solution wound up being a switch to Python 3, but the exact directions for installs aren’t in manual yet.

but I don’t think that would explain CLI failures. Sounds like you’re not too interested in pursuing them.

Duplicati.CommandLine.RecoveryTool.exe would have been next to try, if your restore were still failing.

1 Like