Onedrive V2 Timeout

Hi everyone!

I’m back again, I seem to be having a very cursed weekend with Duplicati :cry:

I’ve attempted to setup a Onedrive V2 personal backend, which grabbed the Oauth token successfully; however, when I attempt to test the connection, it continuously timeouts.

When I try and run the backup, the following happens:

I’ve tried it via docker and the bare metal installation I have, and the same problem presents itself. I’ve removed Duplicati access to Onedrive, reconfigured it, created a folder for it, and still no dice.

Has anybody had any issues with V2 Onedrive, is it due to 2FA auth?

Any insight would be greatly appreciated.

Hope everyone has a happy Spooktober!

Mine is fine, although OneDrive Throttling has impacted some people. Symptoms appear different.

This phrasing sounds like what GUI does.

The appearance of the screenshot is CLI. How did you go from one to the other?
Export As Command-line is a good way normally, although there’s an issue here.
Is screenshot saying it just sits there for a very long time without any more lines?

For another CLI test, you could try out Duplicati.CommandLine.BackendTool.exe.
You might see a different view of whatever’s going on. Test connection is a list.