Not opening on Mac Intel Ventura 13.3.1

Hi. I downloaded Duplicati and installed. It asked for the Mono framework, which I installed as well.
Initially I downloaded the Visual Studio version. Double-clicking Duplicati does not do anything - nothing opens.
I uninstalled Mono and then downloaded the Stable Channel version - still no go.
Uninstalled Duplicati and downloaded beta - still no go.
Any suggestion as to how I can get Duplicati to run on my Intel iMac?



sudo pip3 install pyobjc

If you have several python versions installed, you have to take care to install in the system python3 (it’s the one under /usr/lib IIRC - or /usr/bin)

Thanks for that. When I do that in terminal, this is the result:

SteveAir:~ MacMan$ sudo pip3 install pyobjc


dyld[17985]: dyld cache ‘(null)’ not loaded: syscall to map cache into shared region failed

dyld[17985]: Library not loaded: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

Referenced from: /Library/Frameworks/Python.framework/Versions/3.6/Resources/

Reason: tried: ‘/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation’ (no such file), ‘/System/Volumes/Preboot/Cryptexes/OS/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation’ (no such file), ‘/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation’ (no such file, no dyld cache), ‘/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation’ (no such file)

Abort trap: 6

I think that you are not trying to install into system python.


Thanks for the reply. I appreciate it very much.

I went to the Python site and downloaded Python 3 and installed it. But I still get the same thing when trying to open Duplicati - which is, nothing!

Any suggestions?

a ‘system python’ is python included with the system, not downloaded from an external site. Read the linked post in my previous reply and follow it. No other suggestion from me I’m afraid.

TL;DR it may help if you could find out what Pythons you have, and where they are located.
I don’t understand the advice about /usr/bin/python3, but I’ll point to how Apple set it up.

I don’t have or use a Mac, but tried Google searches such as “CoreFoundation’ (no such file)”.
One point stressed (here as well) is that it’s helpful to know what and where your Pythons are.

5.1. Getting and Installing MacPython says what above install might have done. Please check.
You probably don’t have Python 2.7, as macOS Monterey 12.3 removed it, which broke things.

Possibly you have multiple Python 3. You can view your PATH, and also have which -a read it.
What version of Python is on my Mac? shows how one can do similar test to look for python3.

During Python version transition, there’s a question of how to get the one needed. You need 3.
Operating systems have their own conventions, but I think one is to rely on executable names.

If all else fails and you can’t tell from generic python name, you can ask it python --version.
Adjust that query for other suspected versions, e.g. python3. I doubt python2.7 is still around.

/usr/bin/python3 is now not really Python 3, but a stub, so don’t be fooled by its presence…
macOS Monterey 12.3 will remove Python 2.7 (/usr/bin/python) discusses the Apples changes.
I’m not sure there’s any sort of Python included with the system these days, except that stub…

Duplicati does have ways to steer to the right Python. This is a little different than it was before:

Is there a recent Mac install issue? adds more mud, with a macOS issue that’s fixed in Ventura 13.4.
I don’t know if you saw any signs of that on your 13.3.1 work, but I ran across it, so I’m mentioning it.

I’m hoping that the line below isn’t hurting anything, but I haven’t looked through RumpsRunner.cs…

No, the C# code calls the python interpreter under /usr/bin/python3, not the script.

At least per Apple’s design, that’s the stub, not any type of Python interpreter.
The Python manual said that’s under /Library/Frameworks/Python.framework.

I think you two both actually have a Mac, so you can compare notes on them.
Regardless, it’s good to hear that the leftover python2 might not be the issue.

Are there any new Duplicati or mono processes around? That might be another angle to attack this.


Does your system update the ls -lu time on a file access? Start probably involves mono running and processing the Duplicati code. If you can find its folder, you might ls -lurt to sort by recent reads.