No restore possible from Google Drive


I’m working with a Raspberry Pi 3b/Buster/Domoticz and recently installed Duplicati (all latest versions). I followed the instructions at Backup Domoticz with Duplicati - SANCLA.

Everything went well, no error messages and meanwhile several automatic backups were made at my Google Drive (checked), no errors. However I tried a test restore but can’t reach (the files on) Google Drive?

When I choose the 3d usual recommended restore option (I called my backup “Raspberrypi-TJB-backup”, it says 21,03 MB / 5 Versions) > 1. Select files > “restore files from Raspberrypi-TJB-backup” > in “restore from” I can select between the 5 backups > after that however I only see the content of my RP-drive, no reference or choise to my Google Drive backup map.

I also tried the first option (Direct restore van backup files…) > 1. Backup location > in “storage type” I can now choose “Google Drive” and after entering “path on server” and “AuthID” (testing connection ok) > 2. No encryption > listing backup files progress indicator > 3. Select files > and then the same menu/opitions as mentioned above (select between the 5 backup and only from RP, no reference to the Google Drive backups).

No error messages or whatever, what’s wrong??

Thanks, Theo.

Welcome to the forum @THBR

What does this mean? Did the restore work or not? It’s your source files you restore, from backup files on Google Drive which look completely different. Drive file names will mostly have dblock or dindex in them.

is where you can find these backup files. You should never get a tree view of Google Drive files to restore. You should always see the source files in your backup. They may be less than the total source files on Pi.

I still wonder if this is just a misunderstanding of how the GUI picker for files to restore goes. Don’t expect:

If you hadn’t done the Direct restore, you would not even see the Google Drive folder in routine usage.

  1. Edit backup Source data screen gives you a tree view of files on the Pi to select to be backed up.

  2. Backup

  3. Restore Select files screen gives you a tree view of the backup to select the files to be restored.

Thanks for the response and advice!

I now see that I did not read the restore menu properly, I apologize.

The restore option works fine, but I do get an error message about the three Domoticz database files.

I will open a new topic about this.

Greetings, Theo.