No network drive can be selected as target of the backup

I have a problem with backing up to a NAS with Duplicati 2.0 Beta. I have created the backups on Windows Server 2016 with 6 jobs. The backup is done to a NAS drive. The disadvantage was that the backup only worked when a user is logged in. Since the backup should of course also work when no user is logged in, I installed the application as a Windows service and moved the job data from my user directory to the Duplicati installation directory. When the service starts, I can access the web interface and the jobs are available.

However, I can no longer select a network drive in the jobs. Only the local drives are available as destination. I then entered the path manually, this worked once, and I was able to complete the backup successfully, but one day later Duplicati can no longer find the path (it is however accessible and active). What could be the reason that the network drives I created are no longer displayed as the target. Even if I want to create new jobs, they are no longer selectable.

Error Message is always: The folder \\Backup\ does not exist

Welcome to the forum!

When you run as a service, it is using a different profile. Mapped drives are stored in each profile independently. Another complication: what user account is the service running under? If LocalSystem, it probably cannot use any mapped drives or UNC paths (unless perhaps the NAS allows anonymous access).

You could tie the service to a specific user account (instead of LocalSystem). Hopefully the user/pw is also valid on the NAS. You could then either map the drive letters and save them with that profile so they will be visible when you browse target drives, or you can use UNC paths.

Another option is to not use mapped drives or UNC paths. Use another protocol that is separate from Windows. On my NAS (Synology) I have experimented with both SFTP and WebDAV and both worked well. No issues using these protocols with a service running as LocalSystem.