No connection to Backblaze B2

Hi there, I dug through this forum searching for Error 401. I get this one every time I try to connect with Backblaze. I set the keyID as my B2 Application ID and the applicationKey as the B2 Application Key. I tried this and other combinations, generated a new Master Key and new Application Key. I just can’t get it to work.

Right now the error switched to “Failed to connect: Error: ConnectFailure (The requested address is not valid in this context)”. Hopefully someone know better than me, any help is highly appreciated!

Oh and I use (just installed) Duplicati for macOS (12.0.1 to be exact). I also had to install MonoFramework-MDK- (since I do use VS Code for other stuff and it was mentioned that this version plays nicely with VS Code).

Welcome to the forum!

First, forget the master key. Don’t use that with Duplicati, as it has access to everything in your B2 account. You want to generate an application key with access to the specific bucket you want Duplicati to write to.

I see you tried generating a new application key but you still had trouble. Maybe you didn’t put the values in the right spot?

Here’s an example of how to do this:

Copy the keyID and applicationKey to the clipboard:

B2 Application ID = keyID, and B2 Application Key = applicationKey:

Test the connection:

Hi, thanks for you time and effort! I did exactly that and got the mentioned error messages. To be sure, I generated another application key, but the problem stays the same. Also, I really can’t find anything regarding this hint: “The requested address is not valid in this context”.

Ok, interesting… I don’t know if your issue has anything to do with Duplicati running on MacOS or not. Unfortunately I don’t have access to such a system to test. Perhaps one of the other members of our forum does.

FWIW Backblaze B2 Duplicati backup is working OK here on Windows 10. I don’t have macOS.

On the Destination screen, can you even get the Test connection button to test successfully?

You could try some other program such as Cyberduck to see if it can get in.

There are also lower-level networking tools that you might have, if you’d be willing to explore that.

One simple higher-level test would be to see whether the web browser can get through to these:

these may all be used (via DNS) by using which is where API starts.
Just going there from a web browser, though, you should be redirected to Backblaze home page.

Okay, now this is strange. I tried the same setup as described in my original post but on my MacBook with M1 Chip. Duplicati Backups work flawlessly now and the connection via Cyberduck does as well. My iMac on the other hand still doesn’t get any connection. Not via Duplicati nor Cyberduck.

So it sound like a deeper and even more serious problem which I can’t demand any more help from you.
Thank you so much for your support and thoughts.
I’ll keep you posted whenever I find out what’s causing this issue.

1 Like