Newbie Question: Using Dropbox as Backup Destination


Apologies for the newbie question (I was also using crashplan). I am trying to setup Dropbox as the destination. In the Duplicati screen I have selected Dropbox.

I ASSUME I do not need Dropbox installed, I simply need to be able to get the path on server (URL of the backup folder), but HOW DO I DO THIS? When I just look at the folder with Dropbox web it has a URL of that says …home…

Clearly that’s a folder for everybody in the globe, how can I find out what ‘home’ should be?

OR is it actually the path on the server like: c\users\user\Dropbox\DuplicatiBackups where I MUST have Dropbox installed (this seems a bit weak since I could delete or corrupt that folder locally)? Regardless …Path on Server… is confusing and I have trolled the manual etc etc and cannot find an answer.

Secondly, even though I go through the OAUTH2 signin and get a token, Duplicati ALWAYS tells me I need a valid token. I have repeated this at least 5 times and everytime I get the …Failed to connect: You need an AuthID, you can get it from: etc

I have the authID setup here:

authid ••••••••••••••••••••••••••••••••••••••••••••••••••••••••••••••••x
The authorization token retrieved from Duplicati OAuth Handler
Default value: “”

and here:

Backup destination
Storage Type Dropbox
Path on server The actual Dropbox link to the folder
AuthID dLi0f59i4z4AAA etc

and still the error: …Failed to connect: You need an AuthID, you can get it from: etc

So what do I need to do, this is becoming (nope it actually is) very frustrating. I realise that you are doing this for free, but I still need it to work?

EDIT: It looks to me like you need to put in a Dropbox local folder as the path (then I assume you rely on Dropbox syncing). Apart from the fact that the local dropbox folder could get corrupted thus corrupting the folder in the cloud, the other issue we have is that we are backing up a 150GB GCI. So plenty of space on Dropbox (ie. at least 1 Tb), but VERY limited space locally. So dumping down backups (even incrementals) would kill our GCI very quickly. The bottom line is that I’d rather NOT store backup data locally on the server.

I don’t use Dropbox, so maybe someone who does will come to help, but Google found me this example setup, where it looks like “Path on server” gets a forward slash then desired folder name. Use a different one per job.

There are sometimes two options for “sync” type destinations. One is Duplicati to a “Local folder or drive” that actually gets remote via sync. Drawbacks there, as you note, are local space, and more exposure to damage.

Another option is to work directly with the server maintained by that company, if they permit such a capability. Maybe the error message is off-target? If “Path on server” is an HTTP link, that will probably not be accepted.

Could you please try a forward slash plus folder name? I’m not sure whether the folder must exist in advance. The safest plan might be to create it from the Dropbox UI, give path to Duplicati, then run a “Test connection”.

I think Dropbox works. One can see it with a good amount of usage at

Thanks for the reply. I haven’t tried the local folder option (I will). What you say makes sense. The OAUTH token issue might just be the proverbial red herring. As noted my issue on the GCI instance is that we have a 150Gb drive. We could expand it, but our simple server setup with that drive and one CPU with 5Gb RAM (IIRC) costs us US$100/month. That’s not a lot, but with our budget it sort of is so I’m trying to keep our GCI server config as it is. The other issue, of course, is that I’d need to actually run Dropbox on the server with my account. not such a big deal, but still something I wanted to avoid.

Again, thanks for your help.

And I’m still not getting the concept of using (any of the) proprietary storage mechanisms like Dropbox and say onedrive etc etc. Based on what ts678 has said (and what it looks like when I try to use), you point the proprietary backup to the folder within your system. So near as I can figure, if I put in (Dropbox user) as a destination on the server \MYBACKUP that will be translated c:\users\username\Dropbox\MYBACKUPS.

So why bother at all? why not just say it’s a ‘local folder or drive’ on my computer and point it to:

This would have the same effect since syncing would occur and the backup would eventually be sync’d to Dropbox. The same goes for onedrive or any of the other proprietary backup systems that store data locally and then sync to their cloud.

So I think I am missing something. There seems to be some way (I don’t know how) to save a backup to Dropbox without it going to a local folder or drive (preferably without Dropbox on the system being backed up). Can anyone suggest how this might be accomplished?


OK, so it’s obvious when you know how it works.

  1. You don’t need Dropbox on the system being backed up
  2. The location on the server is the folder you want in Dropbox
  3. BUT if you look at your dropbox root folder, it is under …\Apps\Duplicati backup
  4. So if your folder is MYBACKUPS it will be: …\Apps\Duplicati backup\MYBACKUPS
  5. Folder on Server: should NOT begin with ‘’
  6. If you enter as the folder on server: MYBACKUPS and …\Apps\Duplicati backup\MYBACKUPS does not exist Duplicati will create it

NOW that I know how it works, it is really VERY good. It would be useful if this was explained in the documentation a bit more clearly.

Regardless for me, it is EXACTLY how I wanted it to operate, thank you Duplicati…

Hey folks,
seems that I’m not bright enough to make it…
After putting in this Path for DROPBOX

…\Sicherung\Duplicati backup

it will create the non existing folder + subfolder, but still shows me this error here:

Failed to connect: {“error_summary”: “path/malformed_path/”, “error”: {".tag": “path”, “path”: {".tag": “malformed_path”}}}

What is wrong and how should the pattern be like? (for DB and for Google Drive) - Could you help me out with some examples? I basically just wanna have one folder ‘Sicherung’ and inside the subfolder ‘duplicati’ for the files to save…

thanks for your comments and help :slight_smile: