New Backup to Mega NZ not connecting

I have two issues really, the 2nd created as a result of giving up on solving the 1st.

1st, background & initial issue) I have a long-standing successful backup to Mega NZ but since April failed due to ‘found 2 files that are missing from the remote storage’.

2024-05-17 16:43:58 -03 - [Warning-Duplicati.Library.Main.Operation.FilelistProcessor-MissingFile]: Missing file: duplicati-b6359832c389845229f1c24f60c008191.dblock.zip.aes
2024-05-17 16:43:58 -03 - [Warning-Duplicati.Library.Main.Operation.FilelistProcessor-MissingFile]: Missing file: duplicati-i4462293999024b87930c5b2ae623bafc.dindex.zip.aes
Errors 2
2024-05-17 16:43:58 -03 - [Error-Duplicati.Library.Main.Operation.FilelistProcessor-MissingRemoteFiles]: Found 2 files that are missing from the remote storage, please run repair

Blockquote

Today I have spent hours looking into this. The 2 missing files are definitely present in Mega NZ, although one of them existed 4 times so I renamed the duplicates and kept one. Backup still gave the same errors. Tried repair databased multiple times, which does nothing and tried recreating the database, which then found 3 missing files and 2 errors. Most of the other info in the help I found here is either not what I’m experiencing or is too technical for me to follow, so I gave up and decided to export the task and import as a new backup, which generated issue 2,

2 workaround issue) Testing mega nz connection in the ORIGINAL backup task is successful. For the new backup I changed the name of the destination folder, and Duplicati correctly offered to create this folder. That folder was created, but then Duplicati concludes the test with ‘Failed to connect: missing-folder’. I have tried multiple times and searched forums, but not found a solution to this. To reiterate: The new backup folder is created, and the connection test to my existing Mega nz backup is working fine.

Thanks for any help. I’m not very techy…

Forgive me for double posting. I did find this solution that might work for me too and added a request for more details there Error testing connection to mega.nz - #23 by syscom