Multiple PC's failing backups today

This morning I woke up with all 3 of my Windows 10 PC’s reporting that Duplicati failed to backup to my S3 storage (with iDrive e2).

Version: 2.0.6.3_beta_2021-06-17

Backup Error:
Details: System.AggregateException: One or more errors occurred. —> System.AggregateException: Expected hash not equal to calculated hash —> Amazon.Runtime.AmazonClientException: Expected hash not equal to calculated hash

I tried a repair and this is what got reported:
2022-09-22 09:18:28 -04 - [Error-Duplicati.Library.Main.Operation.RepairHandler-RemoteFileVerificationError]: Failed to perform verification for file: duplicati-20220919T080442Z.dlist.zip.aes, please run verify; message: Remote verification failure: [Extra, C:\ProgramData\USOShared\Logs\System\UpdateSessionOrchestration.8e53f03c-3def-4fd2-92ba-9a3c58181a7a.1.etl]

Error from the verify:
Failed: Unexpected difference in fileset version 1: 9/20/2022 4:03:46 AM (database id: 154), found 97400 entries, but expected 97401**
**Details: Duplicati.Library.Interface.UserInformationException: Unexpected difference in fileset version 1: 9/20/2022 4:03:46 AM (database id: 154), found 97400 entries, but expected 97401

All 3 of these PC’s have their own buckets on iDrive and they also backup locally with Duplicati, the local backups are fine.

Is there a way to fix this? Should I switch to another cloud storage provider? IDrive has been fine for months but I suspect something happened on their end that caused this?

Welcome to the forum @spoolin86

Possibly coincidence, but another backup program began iDrive E2 failures about when you got yours.

kopia list returns inconsistent results on Idrive E2 #2426

It seems kopia with IDrive e2 is not working anymore.

Another person later said:

It worked up until today.

Those posts were Sep 20 and Sep 22. Yours was Sep 21. The details of failure are different from yours, however the backup program and every bit of the code is probably also different. You can search further, should you wish to check for signs of a recent issue (or opinions in general). It’s a relatively new service.

For your issue, let’s see how iDrive works for you today. Maybe you can do an Export As Command-line, changing the target URL to an unused folder, then pass it to Duplicati.CommandLine.BackendTester.exe.

If it’s working again (I assume it worked before…) then we can try to tidy up whatever mess there is now.

I just tried and it works perfectly for me.

@ts678 thanks for the help, yesterday I deleted my backups on IDrive and started fresh. If it happens again I’ll try what you suggested.

@Muhammad_Abrar were you also affected by IDrive or were you using another source? Just curious because if you also were using IDrive then I might consider switching providers.