MS SQL Database not showing up

This may be something I have done wrong during setup but when I am creating backups I am unable to see my SQL instances, however when I end duplicati and run it as an admin I can see them.

So I’m just wondering if:

  1. Duplicati is supposed to run as admin straight away and why is mine not if it should?
  2. How do I make it always run as an admin if it is supposed to?
  3. If admin isn’t needed what do I need to do to have my SQL instances show up?

Hello and welcome to the forum!

By default Duplicati runs at login as the logged-in user. Almost certainly it is NOT elevated (unless your system has UAC disabled, which I don’t recommend). This is sufficient for many users that back up only their user data.

There are ways to get Duplicati to run elevated at logon. Alternatively, you can opt to not run Duplicati at logon but instead run it as a Windows Service. The default behavior when running as a service is that it runs elevated under the LocalSystem context.

To properly back up MS SQL, you will need to run Duplicati elevated one way or another, PLUS you will need to make sure the user Duplicati runs as has SQL “sysadmin” rights on the database instance.

Thanks @drwtsn32 for your reply, how would I go about installing it as a service?

Check this HowTo:

Take special note of some of the later posts in the thread, especially one about the default location for service being vulnerable to major Windows 10 upgrades:

  • v3 - solves the windows update/upgrade problem of deleting C:\Windows\System32\config\systemprofile\AppData\Local\Duplicati