Missing required option: auth-username

So I tried to edit one of my jobs today and after I did I started getting this error whenever I try to connect to the server host: “Missing required option: auth-username”

First curious thing in the edit menu is that Storage Type seems to have change on its own from “OpenStack Object Storage / Swift” to “OpanStack Simple Storage”, so I tried to change it back but same error when I try to test the connection. Same goes for my username and password on that screen they were gone so I had to enter them again but still getting that error…

Here is how it was looking like when I created the job initially:

The only think I can see changed since I created those backup jobs is the version of Duplicaty which is now and was when I created the jobs according to the json exports I made at that time.

So right now I have a job that always end up on this error regardless of what I do (even repair raises it). And obviously loading the json exports I mention above also lead to the same result, or I would not be here…

Any help will be appreciated.

This is unfortunately a bug introduced in version specifically for openstack. You have the option to either modify a javascript file in your browser or export it and import with save immediately as a workaround. This issue has more info:

@Jojo-1000 Thanks for the link, couldn’t seem to find any related issue here on the forums, but it turns out github had it… I will see what I can do with that information.

EDIT: Deleting the broken job (while keeping the database) and then reimporting the job I had already exported with the “Save immediately” option as suggested in that ticket did the trick for me.

1 Like