Mismatching number of blocklist hashes detected on blockset

I have a backup that is backing up to Backblaze B2 and has been working happliy for several months. This morning I had a warning on it that it couldn’t resolve api.backblaze.com. I re-ran the backup and then it said that there was an “unexpected difference in the fileset” I did some quick looking in the forums and found that lots of people were trying a database rebuild and if that didn’t work they deleted/recreated the database. I ended up doing both of those things and now I have:

Warning-Duplicati.Library.Main.Database.LocalRecreateDatabase-MismatchInBlocklistHashCount]: Mismatching number of blocklist hashes detected on blockset 8518. Expected 0 blocklist hashes, but found 5

I’m not really sure what to do next besides just redo the whole backup but I’m on a slow connection and that will probably take a week or more to upload. I’m a fairly new user to Duplicati and not sure on all these ins and outs and any help would be appreciated. Maybe this is a bug?

I looked through this article but I’m not really up on diving that deep into the system: Backup failing due to unexpected difference in fileset

Currently running Duplicati -

The deep dive is not supposed to be needed in beta. That was the workaround for a bug now fixed.

For users, Backup failing due to unexpected difference in fileset retracts that workaround. Now you can (I think) take the error message’s information without the workaround, and run The DELETE command.

Unexpected difference in fileset version 0: 12/5/2018 6:39:53 PM (database id: 3), found 2 entries, but expected 3

is the backup error I got from an FTP failure I forced to test “Unexpected difference in fileset” errors [], and doing a delete of that version took care of it. I haven’t seen other versions, but maybe it’s always on 0…

Did you save your old database before deleting it? If so, it’s possible we can still try the above idea on fixing, otherwise I’m not immediately sure what to say about your new error. Perhaps someone else will comment…

Unfortunately, No I didn’t save my database so I guess I can’t do any further troubleshooting. After I made the post I tried a few things. I did a repair and a verify and now I think my backups are working again. However I’m getting a box at the bottom of the GUI saying there were “warnings” during my backup however when I look at the log I don’t see anything under the warnings sections and I’m also using the “sendd http url” option with dupicatimonitoring.com and it is showing in that interface that there were no warnings also… Is it possible that there is some sort of false warning set in my duplicati install somewhere?? I have 3 backup jobs on my pc and they’re all doing the same thing. One is going to backblaze, another to a local nas share and the third is going to a webdav server.

I am running beta and also getting this error:

Unexpected difference in fileset version 160: 8/13/2018 7:52:24 AM (database id: 2), found 170 entries, but expected 171

I have repaired the database, but when I verify files I get the same error. There is a suggestion to take the error message’s information and run the DELETE command. Can someone explain this a bit more for me so I can fix this error? Thanks.

Using the Command line tools from within the Graphical User Interface is probably the easiest way to run the delete command. When its screen opens, change the Command at top to delete, empty the Commandline arguments box, and use Add advanced option (near bottom) to add –version as given by error message. beta, unlike beta, is supposed to give a version that you can drop right in without translation, however I haven’t seen forum reports other than my own on version 0, which may be a special case. I’m not sure how yours wound up at such an old version, but that’s what it said… A good idea when doing delete (in general but especially in an error situation like this) is to also add and check –dry-run before doing the Run. You can at least confirm no odd failures, and that it in fact intends to delete the version you expect to delete.


This worked! Thanks @ts678 for these additional instructions. Much appreciated.

1 Like