Mega.nz slow upload

Has any other user problems with uploading to mega.nz too
My upload speed is almost ZERO.

When I upload via Browser the speed is alright

as soon as the first block is transfered to mega the speed goes down.

What can be the reason for this strange behaviour??

It looks like you’re using an Experimental version of Duplicati, is it version 2.0.3.1? If so, I’d recommend updating to 2.0.3.3 beta which is likely a more stable version.

Otherwise, I’d suggest checking that you don’t have any throttle settings added to your global or job settings.

Probably the easiest way to do that would be to go to the job menu and select “Export …” -> “As Command-line” then copy / paste that into a post here (be sure to remove / hide any personal information like passwords, email addresses, etc.)

Same behaviour with the latest edition.

This is my command line:

“C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe” backup “mega://Sicherung?xxxxx&auth-password=xxxxx” “xxxx\” “xxxxx\” “xxxxx\” “xxxx\” “xxxxx\” “xxxx\” “xxxxx\” “xxxx\” “xxxxx\” “xxxxx\” “xxxx” --snapshot-policy=Auto --verbose=true --backup-name=Mega-Backup --dbpath=“xxxxxxx” --encryption-module=aes --compression-module=zip --dblock-size=200MB --keep-time=3M --passphrase=“xxxxxx” --send-mail-any-operation=true --send-mail-body="%RESULT%" --send-mail-from=“xxxxxx” --send-mail-level=all --send-mail-password=“xxxxxx” --send-mail-subject=“Duplicati %OPERATIONNAME% report for %backup-name%” --send-mail-to=“xxxxxx” --send-mail-url=tls://mail.gmx.net:587 --send-mail-username=xxxxxx --disable-module=console-password-input --exclude="%MY_DOCUMENTS%\xxxxx" --exclude="%MY_DOCUMENTS%\xxxx" --exclude="%MY_DOCUMENTS%\xxxx" --exclude="%MY_DOCUMENTS%\xxxx" --exclude="%MY_DOCUMENTS%\xxxxx" --exclude="%MY_DOCUMENTS%\xxxx" --exclude="%MY_DOCUMENTS%\xxxxx" --exclude="%MY_DOCUMENTS%\xxxxxx"

Same here. “Uploading verification file …” is shown since hours. Not only one mega account. I have more then one and since some days all of them block my backup jobs.

There is no noteworthy amount of new or changed data.

20180717 05:16:58.992 DUPLICATI Backup started at 17.07.2018 05:16:58
20180717 05:17:02.642 DUPLICATI Checking remote backup …
20180717 05:17:02.642 DUPLICATI Listing remote folder …
20180717 05:17:11.425 DUPLICATI Scanning local files …
20180717 05:17:11.462 DUPLICATI 1559 files need to be examined (9,55 GB) (still counting)
20180717 05:17:16.450 DUPLICATI 2353 files need to be examined (12,52 GB)
20180717 05:17:21.455 DUPLICATI 1543 files need to be examined (10,10 GB)
20180717 05:17:26.455 DUPLICATI 728 files need to be examined (2,83 GB)
20180717 05:17:31.132 DUPLICATI 0 files need to be examined (0 Bytes)
20180717 05:17:32.757 DUPLICATI No remote filesets were deleted
20180717 05:17:32.895 DUPLICATI Uploading file (644,49 KB) …

And then killed it after 6 or 8 hours.

Same behaviour with other mega accounts. Google accounts are still running without problems.

1 Like

So @Alfred_Muhlleitner had issues with 2.0.3.1 experimental (I think) and also “the latest edition” (I don’t know if that’s 2.0.3.3 beta or 2.0.3.9 canary).

What version are you using @thommyX? If you disable upload of the verification file does the job run? (I had an issue with a provider where the first upload of the verification file worked but subsequent ones failed.)

My GUESS is this is a Mega.nz issue since it seems suddenly be showing up in many different (some fairly old) versions of Duplicati.

I made a backup with verification=false and this worked.

Then deleted the duplicati-verification.json File in mega.nz (mega.nz GUI) and then made a backup with verification=true and this stuck again!

Added some data to the source folder and started again with verification=false worked.

Uploading file (125,28 KB) ...
Uploading file (1,26 KB) ...
Uploading file (1,73 MB) ...
No remote filesets were deleted
Compacting not required
Checking remote backup ...
  Listing remote folder ...
Verifying remote backup ...
Remote backup verification completed
  Downloading file (1,73 MB) ...
  Downloading file (13,36 KB) ...
  Downloading file (14,92 MB) ...
  Duration of backup: 00:04:32
  Remote files: 6217
  Remote size: 45,15 GB
  Files added: 1
  Files deleted: 0
  Files changed: 0
  Data uploaded: 1,86 MB
  Data downloaded: 16,67 MB
Backup completed successfully!

Tried again with verification=true => stuck.

The mega-account has space left (about 4GB free) and also the transfer limit is not reached (gui says 16,7MB transfer used, that is nothing, after adding the file transfer is 33,4MB which also is nothing).

Wired problem because I have the exact same problem with 4 mega.nz accounts and 3 other mega.nz work and the 4 worked about 7 months without problems and some days ago all 4 stopped working. No change in the configuration or something else?!?

Good catch! I know I had an issue with box.com where setting --upload-verification-file=true worked once then caused the job to fail (apparently box.com wasn’t happy replacing the existing same-named file).

But I’m not seeing that in @Alfred_Muhlleitner’s exported command line above - so while it’s great that you found that oddity, I’m thinking something else is going on as well. :frowning:

Now I tried a block size of 10 MB and this seems to work…

I’ve been experiencing all the things expressed here, and in other similar posts, so I contacted Mega support (I had just purchased a PRO I subscription for use with Duplicati, and so not happy). Their response was:

Hello,

thank you for your email.

Your issue does not seem to be related with MEGA, since from MEGAsync is working fine.

The issue could be cause by the use of this third party software.

We do not recommend any third-party tools.

Please note that these tools are insecure and do not fully implement our cryptographic protocols, therefore if you cannot access your account, or that third party tool did not work as expected, that could be the reason.
If it is the case, you must use one of our official tools (MEGAsync, MEGAcmd, mobile apps or MEGA in browser) to unlock your account, and stop using this third party tools software.
You will have to wait 30 minutes after log in for your account to be unblocked.

You can also exit it by going to your MEGA account session history and click “LOGOUT” on those “Unknown”/“Linux” sessions.
MEGA

Our onsite download is already using multichannel downloading. Any other third party download client have not been approved or authorized by MEGA and should only be used at your own risk, and we do not give support for that tools.

Also, these foreign tools cannot detect your quota and could limit your bandwidth.

To manage your transfers, the best way is to use MEGAsync - our desktop sync and download/upload client. It can be download here: MEGA

From MEGAsync interface, click the gear icon at the top-right corner and select “Import links” from the dropped-down list.

Kind Regards,
MEGA Support

Indeed, when I checked my Session History I had many, many, ‘unknown’ sessions. My (personal) assessment is that Mega no longer works well with Duplicati, so I’m off to Google Drive or B2 (where my benchmark tests give a few seconds for a test full backup of 200Mb, versus 4 hours plus on Mega!). Mega’s loss…

Hope this helps others…

I had a similar problem. The Mega backup was essentially stuck with no activity in Process Explorer for CPU, IO, and network. I cleared the Mega session list (“Logout other sessions”), erased my backup folder, erased all local Duplicati files, and started a new Backup. That fixed it. Not sure which of these steps made the difference.

OK, update: Backup is stuck mid-way with Mega. CPU and disk idle. TcpView shows minimal, rare network activity.

I cleared the sessions again and it did nothing.