Mac / Firefox scheduling issue


#1

Hi there,
i just installed duplicati on macos 10.13.3. First: Duplicati looks nice and the manually backup does work fast and as expected. But i also do have (tldr: i had no problems! just time problem with german time (DST changes scheduled backup time · Issue #1364 · duplicati/duplicati · GitHub)) problems with the automatic/scheduled sync option:

Version: v2.0.2.21-2.0.2.21_canary_2018-03-06
From: Duplicati Github
tested methods: .dmg and .pkg

  1. I installed Duplicati via the .dmg-file. This installation method doesnt add a login item to my user startup programs. The Tray icon shows the “X”. I did some succesful manual backups but the scheduled never worked. So i added the two different .plist-files in the two folders (as decribed in this thread). Restarted the mac and also looked in the system settings to check if there is no login item when i use the two .plist-files.
    Here: No plist files added automatically by installation. I added both.

  2. I installed Duplicati via the .pkg-file. This time i have a tray .plist-file automatically added by the installer. (Would be enough for me because i only need backups when i am logged in). The Tray icon still shows an X when idle. I have set two scheduled backups but there is no automatic scheduled backups. I also restarted the mac and assured that i only have the tray agent .plist-file.
    Here: Login Item and .plist tray agent added by the .pkg installation.

I read:

My Mono-version (was installed with the .dmg start (1)):
mono -V
Mono JIT compiler version 5.8.0.129 (2017-10/835a98d8559 Fri Feb 23 21:09:37 EST 2018)

Do you have any idea what could be the problem?

Some more informations:
The informations at the top of the page about the next scheduled backup doesnt change. It was 7:30 pm and i scheduled for 8:50 pm. I scheduled another job with a different backupfolder for 9:20 pm. Now its 9:25 pm and the information at the top of the page shows “next backup scheduled: foldername today at 8:50 pm”. So the information at the top of the page doesnt change and also the the second scheduled backup does not start automatically.

@now its 9:27pm and the webinterface shows this informations. Perhaps is there somethin wrong with the time management or its refreshing?

Both scheduled configs are set! (removed pictures cause i am limited to three in one post -.-)

I really would like to use duplicati but without the scheduled backups its more a manually backup rather than a aumatically backup solution…

update: Its now 9:43 pm and i started both backups manually, now i got the following in the webinterface (really looks like duplicati got the wrong time -> duplicati is a hour in the past?):

Sorry for the long post:
Here some new informations: Now its 9:50 pm and the “test-backup” does start automatically. So the install option via .pkg does a valid and functional duplicati installation. Also scheduled backups work. My only problem seems to be that duplicati is an hour back in time.

Github Issue: DST changes scheduled backup time · Issue #1364 · duplicati/duplicati · GitHub


MacOS / OSX service installation
#2

There are many moving parts in the time stuff. Internally, all time is handled as UTC, which causes some logic problems during DST switches (times appear to change, but they are really just ignoring DST). AFAIK, there are no other problems with this approach.

When the times are displayed in the browser, they are converted to the local time (by the browser). If your browser follows your operating system settings, you should get the correct times displayed, but it could be that this is not the case.


#3

You are so right…!
Never recognized that before but my Firefox is not in my MacBooks Timezone -.- Actually i do not know right know what could cause it. If i open http://localhost:8200/ngax/index.html in my safari everything is fine and the times are fully correct.

I have to check where i can edit/correct my firefox browser time.

btw.: i am syncing to “strato hidrive” via sftp. You could add it to the preconfigured cloud storages if you want. It works perfectly with duplicati and got many protocols.

So my Firefox is definitly in the wrong time zone…
Its not a problem with the browser addons also not caused by the privacy protection of firefox itself (firefox displays wrong time zone | Firefox-Hilfeforum | Mozilla-Hilfe)
For the moment i have no idea why my firefox is one hour back…

okay, not it works:
I closed firefox. I changed the macos time to different timezone, saved it, and switched back to my timezone (and automatically setting), then i started firefox again and now i have the right time in firefox and also in duplicati :slight_smile:
thx vor help!


#4

Glad to hear you figured it out!

I went ahead and flagged your post as the solution AND put it in its own topic so the title can better reflect the source of the issue. Let me know if you disagree with either of those.


#5

Fully agree! So others can also get rid of that problem :slight_smile: thanks!