Javascript disabled


#1

I spent a lot of time to find the problem (no script blocking JavaScript) because all I get is a blank screen, could someone add a message to help the next person to run across this?


#2

What did you have to enable?

Trusting anything from localhost on port 8200 should be enough


#3

I think OP means that he forgot noscript was blocking access to the GUI, so it loaded a blank screen. I’ve done that myself a few times. I’m not running noscript right now but I’m guessing it breaks the GUI more “completely” than some sites which just look broken enough that the user remembers to whitelist them. If the page doesn’t load at all, it’s easier to forget that noscript could be the issue.

<noscript>Please enable scripting or turn off script blockers in your browser.</noscript>

in the index.html page, should do the trick.

edit: confirmed, I turned off javascript and localhost:8200 is totally blank, so the line above under the body tag would be a helpful notice.


#4

Ah, makes sense. I thought it was a question about what to allow :slight_smile:


#5

I made a pull request for the warning.